summaryrefslogtreecommitdiff
path: root/net-misc/netifrc/netifrc-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-03 23:49:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-03 23:49:50 +0100
commitc410d7a91a496a4fbbca686c80f7446305222d55 (patch)
tree8ba974498cd1061dd4e883a34bd5e9be93a95214 /net-misc/netifrc/netifrc-9999.ebuild
parentc99c2410831577bef101e22948e954f85f56cba1 (diff)
gentoo auto-resync : 03:10:2023 - 23:49:49
Diffstat (limited to 'net-misc/netifrc/netifrc-9999.ebuild')
-rw-r--r--net-misc/netifrc/netifrc-9999.ebuild19
1 files changed, 16 insertions, 3 deletions
diff --git a/net-misc/netifrc/netifrc-9999.ebuild b/net-misc/netifrc/netifrc-9999.ebuild
index 177d61a18ee9..54f749377303 100644
--- a/net-misc/netifrc/netifrc-9999.ebuild
+++ b/net-misc/netifrc/netifrc-9999.ebuild
@@ -19,16 +19,24 @@ else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi
-LICENSE="BSD-2"
+LICENSE="BSD-2 GPL-2"
SLOT="0"
IUSE="+dhcp"
RDEPEND="
sys-apps/gentoo-functions
>=sys-apps/openrc-0.15
- dhcp? ( || ( net-misc/dhcpcd net-misc/dhcp[client] ) )
+ dhcp? (
+ || (
+ net-misc/dhcpcd
+ net-misc/dhcp[client]
+ sys-apps/busybox
+ )
+ )
+"
+BDEPEND="
+ kernel_linux? ( virtual/pkgconfig )
"
-BDEPEND="kernel_linux? ( virtual/pkgconfig )"
src_prepare() {
if [[ ${PV} == 9999 ]] ; then
@@ -69,6 +77,7 @@ src_install() {
pkg_postinst() {
udev_reload
+
if [[ ! -e "${EROOT}"/etc/conf.d/net && -z ${REPLACING_VERSIONS} ]]; then
elog "The network configuration scripts will use dhcp by"
elog "default to set up your interfaces."
@@ -76,3 +85,7 @@ pkg_postinst() {
elog "${EROOT}/usr/share/doc/${P}/README"
fi
}
+
+pkg_postrm() {
+ udev_reload
+}