summaryrefslogtreecommitdiff
path: root/net-misc/netifrc/netifrc-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-10 22:36:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-10 22:36:46 +0100
commit783da4542a9c3e0e1ec703644212707cde610679 (patch)
tree3e0cf56ac37ddf9d5fdc6ff0ced9135b1c7fc5e0 /net-misc/netifrc/netifrc-9999.ebuild
parentd0041c590ed45bbfeae458ea926e36bc64e41dd7 (diff)
gentoo auto-resync : 10:09:2023 - 22:36:45
Diffstat (limited to 'net-misc/netifrc/netifrc-9999.ebuild')
-rw-r--r--net-misc/netifrc/netifrc-9999.ebuild20
1 files changed, 12 insertions, 8 deletions
diff --git a/net-misc/netifrc/netifrc-9999.ebuild b/net-misc/netifrc/netifrc-9999.ebuild
index 67e26c8b1ccf..177d61a18ee9 100644
--- a/net-misc/netifrc/netifrc-9999.ebuild
+++ b/net-misc/netifrc/netifrc-9999.ebuild
@@ -1,16 +1,18 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit systemd udev
DESCRIPTION="Gentoo Network Interface Management Scripts"
-HOMEPAGE="https://www.gentoo.org/proj/en/base/openrc/"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Netifrc"
-if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/netifrc.git"
- #EGIT_REPO_URI="https://github.com/gentoo/${PN}" # Alternate
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="
+ https://anongit.gentoo.org/git/proj/netifrc.git
+ https://github.com/gentoo/${PN}
+ "
inherit git-r3
else
SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.gz"
@@ -21,13 +23,15 @@ LICENSE="BSD-2"
SLOT="0"
IUSE="+dhcp"
-RDEPEND="sys-apps/gentoo-functions
+RDEPEND="
+ sys-apps/gentoo-functions
>=sys-apps/openrc-0.15
- dhcp? ( || ( net-misc/dhcpcd net-misc/dhcp[client] ) )"
+ dhcp? ( || ( net-misc/dhcpcd net-misc/dhcp[client] ) )
+"
BDEPEND="kernel_linux? ( virtual/pkgconfig )"
src_prepare() {
- if [[ ${PV} == "9999" ]] ; then
+ if [[ ${PV} == 9999 ]] ; then
local ver="git-${EGIT_VERSION:0:6}"
sed -i "/^GITVER[[:space:]]*=/s:=.*:=${ver}:" mk/git.mk || die
einfo "Producing ChangeLog from Git history"