summaryrefslogtreecommitdiff
path: root/net-misc/netifrc/netifrc-0.7.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-01 05:52:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-01 05:52:14 +0000
commitbcc717ffe9cc7dccbea636cefb524a54429ed3c5 (patch)
tree86b68b64cb19bcf8d3c1fb98fc9ca858dc6b0e46 /net-misc/netifrc/netifrc-0.7.5.ebuild
parentbf90f82fef4fc737c88b58cd31428ad4355c17fa (diff)
gentoo auto-resync : 01:01:2024 - 05:52:14
Diffstat (limited to 'net-misc/netifrc/netifrc-0.7.5.ebuild')
-rw-r--r--net-misc/netifrc/netifrc-0.7.5.ebuild74
1 files changed, 0 insertions, 74 deletions
diff --git a/net-misc/netifrc/netifrc-0.7.5.ebuild b/net-misc/netifrc/netifrc-0.7.5.ebuild
deleted file mode 100644
index 5f51fbe7ef3f..000000000000
--- a/net-misc/netifrc/netifrc-0.7.5.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit systemd udev
-
-DESCRIPTION="Gentoo Network Interface Management Scripts"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Netifrc"
-
-if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/netifrc.git"
- #EGIT_REPO_URI="https://github.com/gentoo/${PN}" # Alternate
- inherit git-r3
-else
- SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-fi
-
-LICENSE="BSD-2 GPL-2"
-SLOT="0"
-IUSE="+dhcp"
-
-RDEPEND="sys-apps/gentoo-functions
- >=sys-apps/openrc-0.15
- dhcp? ( || ( net-misc/dhcpcd net-misc/dhcp[client] ) )"
-BDEPEND="kernel_linux? ( virtual/pkgconfig )"
-
-src_prepare() {
- if [[ ${PV} == "9999" ]] ; then
- local ver="git-${EGIT_VERSION:0:6}"
- sed -i "/^GITVER[[:space:]]*=/s:=.*:=${ver}:" mk/git.mk || die
- einfo "Producing ChangeLog from Git history"
- GIT_DIR="${S}/.git" git log >"${S}"/ChangeLog
- fi
-
- default
-}
-
-src_compile() {
- MAKE_ARGS=(
- PREFIX="${EPREFIX}"
- UPREFIX="${EPREFIX}/usr"
- UDEVDIR="${EPREFIX}$(get_udevdir)"
- LIBEXECDIR="${EPREFIX}/lib/${PN}"
- PF="${PF}"
- )
-
- emake "${MAKE_ARGS[@]}" all
-}
-
-src_install() {
- emake "${MAKE_ARGS[@]}" DESTDIR="${D}" install
- dodoc README CREDITS FEATURE-REMOVAL-SCHEDULE STYLE TODO
-
- # Install the service file
- local LIBEXECDIR="${EPREFIX}/lib/${PN}"
- sed "s:@LIBEXECDIR@:${LIBEXECDIR}:" "${S}/systemd/net_at.service.in" > "${T}/net_at.service" || die
- systemd_newunit "${T}/net_at.service" 'net@.service'
-
- local UNIT_DIR="$(systemd_get_systemunitdir)"
- UNIT_DIR="${UNIT_DIR#"${EPREFIX}"}"
- dosym net@.service "${UNIT_DIR}/net@lo.service"
-}
-
-pkg_postinst() {
- udev_reload
- if [[ ! -e "${EROOT}"/etc/conf.d/net && -z ${REPLACING_VERSIONS} ]]; then
- elog "The network configuration scripts will use dhcp by"
- elog "default to set up your interfaces."
- elog "If you need to set up something more complete, see"
- elog "${EROOT}/usr/share/doc/${P}/README"
- fi
-}