summaryrefslogtreecommitdiff
path: root/net-misc/netevent/netevent-2.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-25 23:59:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-25 23:59:45 +0100
commit6243676c91946098c06d42bc87b5eb99aac40bf0 (patch)
treee6de308ba22148b4898b67b049c7f017ece8fea2 /net-misc/netevent/netevent-2.2.2.ebuild
parentb987a550f067c3da93b0664cf1fdc8a624c0aa38 (diff)
gentoo auto-resync : 25:04:2024 - 23:59:45
Diffstat (limited to 'net-misc/netevent/netevent-2.2.2.ebuild')
-rw-r--r--net-misc/netevent/netevent-2.2.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-misc/netevent/netevent-2.2.2.ebuild b/net-misc/netevent/netevent-2.2.2.ebuild
new file mode 100644
index 000000000000..c882e035e5cd
--- /dev/null
+++ b/net-misc/netevent/netevent-2.2.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tool to share Linux event devices with other machines"
+HOMEPAGE="https://github.com/Blub/netevent"
+SRC_URI="https://github.com/Blub/netevent/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="doc"
+
+BDEPEND="
+ doc? ( dev-python/docutils )
+"
+
+src_configure() {
+ tc-export CXX
+
+ # Not Autoconf.
+ RST2MAN=$(type -P rst2man rst2man.py) \
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ $(use_enable doc) \
+ || die
+}
+
+src_compile() {
+ emake CPPFLAGS="-Wall -Wno-unknown-pragmas"
+}