summaryrefslogtreecommitdiff
path: root/net-misc/nemesis/nemesis-1.7-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /net-misc/nemesis/nemesis-1.7-r1.ebuild
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'net-misc/nemesis/nemesis-1.7-r1.ebuild')
-rw-r--r--net-misc/nemesis/nemesis-1.7-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-misc/nemesis/nemesis-1.7-r1.ebuild b/net-misc/nemesis/nemesis-1.7-r1.ebuild
new file mode 100644
index 000000000000..f34383cb354c
--- /dev/null
+++ b/net-misc/nemesis/nemesis-1.7-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="A commandline-based, portable human IP stack for UNIX/Linux"
+HOMEPAGE="https://github.com/libnet/nemesis"
+SRC_URI="https://github.com/libnet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~sparc ~x86"
+
+RDEPEND="
+ net-libs/libnet:1.1
+ net-libs/libpcap
+"
+DEPEND="
+ ${RDEPEND}
+"
+DOCS="ChangeLog.md docs/CONTRIBUTING.md docs/CREDITS README.md"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7-fno-common.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}