summaryrefslogtreecommitdiff
path: root/net-misc/ncp/ncp-1.2.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/ncp/ncp-1.2.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/ncp/ncp-1.2.4.ebuild')
-rw-r--r--net-misc/ncp/ncp-1.2.4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-misc/ncp/ncp-1.2.4.ebuild b/net-misc/ncp/ncp-1.2.4.ebuild
new file mode 100644
index 000000000000..12a07aed2c18
--- /dev/null
+++ b/net-misc/ncp/ncp-1.2.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="utility for copying files in a LAN (npoll, npush)"
+HOMEPAGE="http://www.fefe.de/ncp/"
+SRC_URI="http://dl.fefe.de/${P}.tar.bz2"
+
+LICENSE="public-domain" # mail from author, bug 446540
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="diet"
+
+RDEPEND=""
+DEPEND=">=dev-libs/libowfat-0.28-r1
+ diet? ( dev-libs/dietlibc )"
+
+src_prepare() {
+ rm Makefile || die
+ sed -e '/^ncp:/,+5s:strip:#strip:' \
+ -i GNUmakefile || die
+}
+
+src_compile() {
+ emake \
+ CC="$(use diet && echo "diet -Os ")$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -I/usr/include/libowfat" \
+ LDFLAGS="${LDFLAGS}" \
+ STRIP="#"
+}
+
+src_install() {
+ dobin ${PN}
+ dosym ${PN} /usr/bin/npoll
+ dosym ${PN} /usr/bin/npush
+
+ doman ncp.1 npush.1
+ dodoc NEWS
+}