summaryrefslogtreecommitdiff
path: root/net-misc/ncp/ncp-1.2.4-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /net-misc/ncp/ncp-1.2.4-r2.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'net-misc/ncp/ncp-1.2.4-r2.ebuild')
-rw-r--r--net-misc/ncp/ncp-1.2.4-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/ncp/ncp-1.2.4-r2.ebuild b/net-misc/ncp/ncp-1.2.4-r2.ebuild
new file mode 100644
index 000000000000..cb6d5545c438
--- /dev/null
+++ b/net-misc/ncp/ncp-1.2.4-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utility for copying files in a LAN (npoll, npush)"
+HOMEPAGE="https://www.fefe.de/ncp/"
+SRC_URI="https://dl.fefe.de/${P}.tar.bz2"
+
+LICENSE="public-domain" # mail from author, bug 446540
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=dev-libs/libowfat-0.28-r1[-diet]"
+
+PATCHES=( "${FILESDIR}/${P}-fix-makefile.patch" )
+
+src_prepare() {
+ default
+ rm Makefile || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -I/usr/include/libowfat" \
+ LDFLAGS="${LDFLAGS}" \
+ STRIP="#"
+}
+
+src_install() {
+ dobin ${PN}
+ dosym ${PN} /usr/bin/npoll
+ dosym ${PN} /usr/bin/npush
+
+ doman ncp.1 npush.1
+ dodoc NEWS
+}