summaryrefslogtreecommitdiff
path: root/net-misc/ncman/ncman-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /net-misc/ncman/ncman-9999.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'net-misc/ncman/ncman-9999.ebuild')
-rw-r--r--net-misc/ncman/ncman-9999.ebuild25
1 files changed, 19 insertions, 6 deletions
diff --git a/net-misc/ncman/ncman-9999.ebuild b/net-misc/ncman/ncman-9999.ebuild
index 54dde8ba11c3..045965709b3d 100644
--- a/net-misc/ncman/ncman-9999.ebuild
+++ b/net-misc/ncman/ncman-9999.ebuild
@@ -1,21 +1,34 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit meson git-r3
-COMMIT="bca0dc0a835f8a267be28d32b49775a50543d081"
+inherit flag-o-matic meson
+COMMIT=""
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI=https://github.com/l4rzy/ncman.git
+else
+ SRC_URI="https://github.com/l4rzy/ncman/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
DESCRIPTION="An ncurses UI for connman, forked from connman-json-client"
HOMEPAGE="https://github.com/l4rzy/ncman"
-EGIT_REPO_URI=https://github.com/l4rzy/ncman.git
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
IUSE=""
RDEPEND="dev-libs/json-c:0=
>=sys-apps/dbus-1.4
sys-libs/ncurses:0="
DEPEND="${RDEPEND}"
+
+[[ ${PV} == *9999* ]] || S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_prepare() {
+ default
+ append-cflags "-D_POSIX_C_SOURCE=200809L"
+}