summaryrefslogtreecommitdiff
path: root/net-misc/modemmanager/modemmanager-1.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
commitab3da91fb6c91a9df52fff8f991570f456fd3c7a (patch)
treee8f3bfa2c6c3d20ec3b9c352c839e23949068b6b /net-misc/modemmanager/modemmanager-1.10.0.ebuild
parent6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (diff)
gentoo resync : 18.12.2020
Diffstat (limited to 'net-misc/modemmanager/modemmanager-1.10.0.ebuild')
-rw-r--r--net-misc/modemmanager/modemmanager-1.10.0.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/net-misc/modemmanager/modemmanager-1.10.0.ebuild b/net-misc/modemmanager/modemmanager-1.10.0.ebuild
index 0973aa512edd..7f108b8d46e9 100644
--- a/net-misc/modemmanager/modemmanager-1.10.0.ebuild
+++ b/net-misc/modemmanager/modemmanager-1.10.0.ebuild
@@ -5,7 +5,7 @@ EAPI=6
GNOME2_LA_PUNT="yes"
VALA_USE_DEPEND="vapigen"
-inherit gnome2 readme.gentoo-r1 systemd udev vala
+inherit gnome2 readme.gentoo-r1 systemd toolchain-funcs udev vala
DESCRIPTION="Modem and mobile broadband management libraries"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/ModemManager/"
@@ -75,10 +75,11 @@ src_configure() {
$(use_enable vala)
)
if use elogind; then
+ local pkgconfig="$(tc-getPKG_CONFIG)"
myconf+=(
--with-systemd-suspend-resume
- LIBSYSTEMD_LOGIN_CFLAGS=`pkg-config --cflags "libelogind" 2>/dev/null`
- LIBSYSTEMD_LOGIN_LIBS=`pkg-config --libs "libelogind" 2>/dev/null`
+ LIBSYSTEMD_LOGIN_CFLAGS="$(${pkgconfig} --cflags "libelogind")"
+ LIBSYSTEMD_LOGIN_LIBS="$(${pkgconfig} --libs "libelogind")"
)
fi
gnome2_src_configure "${myconf[@]}"