summaryrefslogtreecommitdiff
path: root/net-misc/mediatomb/files/mediatomb-0.12.1-system-uuid.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/mediatomb/files/mediatomb-0.12.1-system-uuid.patch
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/mediatomb/files/mediatomb-0.12.1-system-uuid.patch')
-rw-r--r--net-misc/mediatomb/files/mediatomb-0.12.1-system-uuid.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/mediatomb/files/mediatomb-0.12.1-system-uuid.patch b/net-misc/mediatomb/files/mediatomb-0.12.1-system-uuid.patch
new file mode 100644
index 000000000000..053f18cea879
--- /dev/null
+++ b/net-misc/mediatomb/files/mediatomb-0.12.1-system-uuid.patch
@@ -0,0 +1,36 @@
+use libuuid from the system rather than local bundled code
+
+http://bugs.gentoo.org/270830
+
+--- a/build/Makefile.am
++++ b/build/Makefile.am
+@@ -58,6 +58,7 @@ mediatomb_CXXFLAGS = -I$(top_srcdir)/src \
+ mediatomb_LDADD = \
+ libmediatomb.a \
+ $(top_srcdir)/tombupnp/build/libtombupnp.a \
++ -luuid \
+ $(LIBEXIF_LDFLAGS) \
+ $(ZLIB_LDFLAGS) \
+ $(EXPAT_LDFLAGS) \
+--- a/build/libmediatomb_src
++++ b/build/libmediatomb_src
+@@ -231,19 +231,6 @@ libmediatomb_a_SOURCES = \
+ ../src/url.h \
+ ../src/url_request_handler.cc \
+ ../src/url_request_handler.h \
+-../src/uuid/clear.c \
+-../src/uuid/compare.c \
+-../src/uuid/copy.c \
+-../src/uuid/gen_uuid.c \
+-../src/uuid/isnull.c \
+-../src/uuid/pack.c \
+-../src/uuid/parse.c \
+-../src/uuid/unpack.c \
+-../src/uuid/unparse.c \
+-../src/uuid/uuid.h \
+-../src/uuid/uuidP.h \
+-../src/uuid/uuid_time.c \
+-../src/uuid/uuid_types.h \
+ ../src/web/action.cc \
+ ../src/web/add.cc \
+ ../src/web/add_object.cc \