summaryrefslogtreecommitdiff
path: root/net-misc/linuxptp/linuxptp-1.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/linuxptp/linuxptp-1.8.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/linuxptp/linuxptp-1.8.ebuild')
-rw-r--r--net-misc/linuxptp/linuxptp-1.8.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/linuxptp/linuxptp-1.8.ebuild b/net-misc/linuxptp/linuxptp-1.8.ebuild
new file mode 100644
index 000000000000..4e1f587b8bbb
--- /dev/null
+++ b/net-misc/linuxptp/linuxptp-1.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit linux-info
+
+DESCRIPTION="The Linux Precision Time Protocol (PTP) implementation"
+HOMEPAGE="http://linuxptp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/v${PV}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="PPS NETWORK_PHY_TIMESTAMPING PTP_1588_CLOCK"
+
+src_compile() {
+ export EXTRA_CFLAGS=${CFLAGS}
+ emake prefix=/usr mandir=/usr/share/man
+}
+
+src_install() {
+ emake \
+ prefix="${D}"/usr \
+ mandir="${D}"/usr/share/man \
+ infodir="${D}"/usr/share/info \
+ libdir="${D}"/usr/$(get_libdir) \
+ install
+
+ dodoc README.org
+}