summaryrefslogtreecommitdiff
path: root/net-misc/linux-eoip/linux-eoip-0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/linux-eoip/linux-eoip-0.5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/linux-eoip/linux-eoip-0.5.ebuild')
-rw-r--r--net-misc/linux-eoip/linux-eoip-0.5.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/linux-eoip/linux-eoip-0.5.ebuild b/net-misc/linux-eoip/linux-eoip-0.5.ebuild
new file mode 100644
index 000000000000..89b53995b2a9
--- /dev/null
+++ b/net-misc/linux-eoip/linux-eoip-0.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit eutils autotools-utils
+
+DESCRIPTION="Linux support for proprietary MIkrotik EoIP protocol"
+HOMEPAGE="https://code.google.com/p/linux-eoip/"
+SRC_URI="https://linux-eoip.googlecode.com/files/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/lzo:2
+ "
+
+RDEPEND="${DEPEND}"
+DOCS=( README )
+
+src_prepare() {
+ esvn_clean
+ sed -e 's/bin_PROGRAMS/sbin_PROGRAMS/g' -i Makefile.am
+ autotools-utils_src_prepare
+}
+
+src_install() {
+ autotools-utils_src_install
+ insinto /etc
+ doins vip.cfg eoip.cfg
+}