summaryrefslogtreecommitdiff
path: root/net-misc/keychain/keychain-2.8.5-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-26 00:13:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-26 00:13:39 +0100
commit81a92c310907a51d2a03b6d470f4276a7d7ac00c (patch)
tree360fadf6d50d331d696d3bf14d3acc328b873dc3 /net-misc/keychain/keychain-2.8.5-r2.ebuild
parentc7b5a281b2f19df584053abc11abb47ccad9c381 (diff)
gentoo auto-resync : 26:04:2023 - 00:13:39
Diffstat (limited to 'net-misc/keychain/keychain-2.8.5-r2.ebuild')
-rw-r--r--net-misc/keychain/keychain-2.8.5-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-misc/keychain/keychain-2.8.5-r2.ebuild b/net-misc/keychain/keychain-2.8.5-r2.ebuild
new file mode 100644
index 000000000000..6bb4d3533258
--- /dev/null
+++ b/net-misc/keychain/keychain-2.8.5-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Agent manager for OpenSSH, ssh.com, Sun SSH, and GnuPG"
+HOMEPAGE="https://www.funtoo.org/Keychain"
+SRC_URI="https://github.com/funtoo/keychain/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+BDEPEND="dev-lang/perl"
+
+PATCHES=(
+ # Patches from Debian
+ "${FILESDIR}/${P}-malformed-ssh-key.patch"
+ "${FILESDIR}/${P}-typos.patch"
+ "${FILESDIR}/${P}-empty-ssh-askpass.patch"
+)
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc ChangeLog README.md
+}