summaryrefslogtreecommitdiff
path: root/net-misc/kea/kea-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /net-misc/kea/kea-9999.ebuild
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'net-misc/kea/kea-9999.ebuild')
-rw-r--r--net-misc/kea/kea-9999.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/net-misc/kea/kea-9999.ebuild b/net-misc/kea/kea-9999.ebuild
index 3968b59aff2f..75288a0c58a2 100644
--- a/net-misc/kea/kea-9999.ebuild
+++ b/net-misc/kea/kea-9999.ebuild
@@ -1,15 +1,14 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit toolchain-funcs user
-MY_PV="${PV//_alpha/a}"
-MY_PV="${MY_PV//_beta/b}"
-MY_PV="${MY_PV//_rc/rc}"
-MY_PV="${MY_PV//_p/-P}"
+MY_PV="${PV//_p/-P}"
+MY_PV="${MY_PV/_/-}"
MY_P="${PN}-${MY_PV}"
+
DESCRIPTION="High-performance production grade DHCPv4 & DHCPv6 server"
HOMEPAGE="http://www.isc.org/kea/"
if [[ ${PV} = 9999* ]] ; then
@@ -18,19 +17,22 @@ if [[ ${PV} = 9999* ]] ; then
else
SRC_URI="ftp://ftp.isc.org/isc/kea/${MY_P}.tar.gz
ftp://ftp.isc.org/isc/kea/${MY_PV}/${MY_P}.tar.gz"
+ [[ "${PV}" == *_beta* ]] || [[ "${PV}" == *_rc* ]] || \
KEYWORDS="~amd64 ~x86"
fi
LICENSE="ISC BSD SSLeay GPL-2" # GPL-2 only for init script
SLOT="0"
-IUSE="openssl samples"
+IUSE="mysql openssl postgres samples"
DEPEND="
dev-libs/boost:=
dev-cpp/gtest
dev-libs/log4cplus
+ mysql? ( dev-db/mysql-connector-c )
!openssl? ( dev-libs/botan:0= )
- openssl? ( dev-libs/openssl:= )
+ openssl? ( dev-libs/openssl:0= )
+ postgres? ( dev-db/postgresql:* )
"
RDEPEND="${DEPEND}"
@@ -47,7 +49,9 @@ src_prepare() {
src_configure() {
local myeconfargs=(
+ $(use_with mysql)
$(use_with openssl)
+ $(use_with postgres pgsql)
$(use_enable samples install-configurations)
--disable-static
--without-werror