summaryrefslogtreecommitdiff
path: root/net-misc/kafkacat/kafkacat-1.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-15 01:47:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-15 01:47:28 +0100
commitf208e35deefe1ee6fe6722cec9ad8cc12e92e638 (patch)
treef63456d14b948e3a902ace235a9961865728faaf /net-misc/kafkacat/kafkacat-1.7.1.ebuild
parent4392d53af7ce45ccfe6eb14146479ef0e2bd790a (diff)
gentoo auto-resync : 15:10:2022 - 01:47:28
Diffstat (limited to 'net-misc/kafkacat/kafkacat-1.7.1.ebuild')
-rw-r--r--net-misc/kafkacat/kafkacat-1.7.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/kafkacat/kafkacat-1.7.1.ebuild b/net-misc/kafkacat/kafkacat-1.7.1.ebuild
new file mode 100644
index 000000000000..9534872d1cd2
--- /dev/null
+++ b/net-misc/kafkacat/kafkacat-1.7.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+MY_PN=kcat
+
+inherit toolchain-funcs
+
+DESCRIPTION="Generic command line non-JVM Apache Kafka producer and consumer"
+HOMEPAGE="https://github.com/edenhill/kcat"
+SRC_URI="https://github.com/edenhill/kcat/archive/${PV}.tar.gz -> ${MY_PN}-${PV}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+avro +json"
+
+DEPEND=">=dev-libs/librdkafka-0.9.4
+ avro? (
+ dev-libs/avro-c
+ dev-libs/libserdes
+ )
+ json? ( dev-libs/yajl )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_configure() {
+ econf $(use_enable avro) $(use_enable json) --cc="$(tc-getCC)"
+}
+
+src_install() {
+ default
+ dodoc CHANGELOG.md
+ doman ${MY_PN}.1
+}
+
+pkg_postinst() {
+ ewarn "Note that starting with version 1.7.1 the executable name"
+ ewarn "was changed from kafkacat to kcat"
+}