summaryrefslogtreecommitdiff
path: root/net-misc/jwhois/jwhois-4.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/jwhois/jwhois-4.0-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/jwhois/jwhois-4.0-r1.ebuild')
-rw-r--r--net-misc/jwhois/jwhois-4.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-misc/jwhois/jwhois-4.0-r1.ebuild b/net-misc/jwhois/jwhois-4.0-r1.ebuild
new file mode 100644
index 000000000000..aa43e9ef17ad
--- /dev/null
+++ b/net-misc/jwhois/jwhois-4.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Advanced Internet Whois client capable of recursive queries"
+HOMEPAGE="https://www.gnu.org/software/jwhois/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+IUSE="idn nls"
+
+RDEPEND="idn? ( net-dns/libidn )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-connect-logic.patch #208875
+}
+
+src_configure() {
+ econf \
+ --localstatedir="${EPREFIX}/var/cache" \
+ --without-cache \
+ $(use_enable nls) \
+ $(use_with idn libidn)
+}