summaryrefslogtreecommitdiff
path: root/net-misc/jlj/jlj-2.12-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-07 11:03:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-07 11:03:14 +0100
commit957235cf19a691360c720f7913672adda4258ed0 (patch)
tree812bba7928f4293ead05a7ee9c1ac39c5ef9f12e /net-misc/jlj/jlj-2.12-r1.ebuild
parent62f67115b5c46134c34f88f4b1cbdacc19384c0a (diff)
gentoo resync : 07.10.2018
Diffstat (limited to 'net-misc/jlj/jlj-2.12-r1.ebuild')
-rw-r--r--net-misc/jlj/jlj-2.12-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-misc/jlj/jlj-2.12-r1.ebuild b/net-misc/jlj/jlj-2.12-r1.ebuild
new file mode 100644
index 000000000000..5534c8e01b5a
--- /dev/null
+++ b/net-misc/jlj/jlj-2.12-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Simple console LiveJournal entry system"
+HOMEPAGE="http://umlautllama.com/projects/perl/#jlj"
+SRC_URI="http://umlautllama.com/projects/perl/${PN}_${PV}.tar.gz"
+
+LICENSE="freedist"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+SLOT="0"
+
+DEPEND="dev-lang/perl"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ newbin ${PN}.pl ${PN}
+ newdoc .livejournal.rc livejournal.rc
+ dodoc README.JLJ
+}
+
+pkg_postinst() {
+ elog "README.JLJ and a sample livejournal.rc have been installed to"
+ elog "/usr/share/doc/${PF}/"
+}