summaryrefslogtreecommitdiff
path: root/net-misc/iperf/iperf-3.8.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /net-misc/iperf/iperf-3.8.1.ebuild
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'net-misc/iperf/iperf-3.8.1.ebuild')
-rw-r--r--net-misc/iperf/iperf-3.8.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/iperf/iperf-3.8.1.ebuild b/net-misc/iperf/iperf-3.8.1.ebuild
new file mode 100644
index 000000000000..cb655f6b4782
--- /dev/null
+++ b/net-misc/iperf/iperf-3.8.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A TCP, UDP, and SCTP network bandwidth measurement tool"
+HOMEPAGE="https://github.com/esnet/iperf/"
+SRC_URI="https://github.com/esnet/iperf/archive/${PV/_/}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint"
+IUSE="libressl profiling sctp static-libs"
+
+DEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ sctp? ( net-misc/lksctp-tools )
+"
+RDEPEND="
+ ${DEPEND}
+"
+S=${WORKDIR}/${P/_/}
+DOCS="README.md RELNOTES.md"
+
+src_configure() {
+ econf \
+ $(use_enable profiling) \
+ $(use_enable static-libs static) \
+ $(use_with sctp)
+}
+
+src_install() {
+ default
+ newconfd "${FILESDIR}"/iperf.confd iperf3
+ newinitd "${FILESDIR}"/iperf3.initd iperf3
+ find "${ED}" -name '*.la' -delete || die
+}