summaryrefslogtreecommitdiff
path: root/net-misc/iperf/iperf-2.0.14a.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
commiteab5731cdf11d4ae8cdf111461d46fd96c5bdd37 (patch)
treece35c6d01b5ff5de95c3a20fef853b9a6518ad2e /net-misc/iperf/iperf-2.0.14a.ebuild
parentb7ebc951da8800f711142f69d9d958bde67a112d (diff)
gentoo resync : 04.05.2019
Diffstat (limited to 'net-misc/iperf/iperf-2.0.14a.ebuild')
-rw-r--r--net-misc/iperf/iperf-2.0.14a.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/iperf/iperf-2.0.14a.ebuild b/net-misc/iperf/iperf-2.0.14a.ebuild
new file mode 100644
index 000000000000..b680ce3d38bb
--- /dev/null
+++ b/net-misc/iperf/iperf-2.0.14a.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Tool to measure IP bandwidth using UDP or TCP"
+HOMEPAGE="http://iperf2.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}2/${PN}-2.0.13.tar.gz"
+
+LICENSE="HPND"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~m68k-mint"
+IUSE="ipv6 threads debug"
+
+DOCS="INSTALL README"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.12-ipv6.patch
+ "${FILESDIR}"/${P}.patch
+)
+S=${WORKDIR}/${PN}-2.0.13
+
+src_configure() {
+ econf \
+ $(use_enable debug debuginfo) \
+ $(use_enable ipv6) \
+ $(use_enable threads)
+}
+
+src_install() {
+ default
+ dodoc doc/*
+ newinitd "${FILESDIR}"/${PN}.initd-r1 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}