summaryrefslogtreecommitdiff
path: root/net-misc/igmpproxy/igmpproxy-0.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:52:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:52:04 +0100
commit71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /net-misc/igmpproxy/igmpproxy-0.2.1.ebuild
parent6612a728ea11526a849618ec515ad57131d64416 (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'net-misc/igmpproxy/igmpproxy-0.2.1.ebuild')
-rw-r--r--net-misc/igmpproxy/igmpproxy-0.2.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-misc/igmpproxy/igmpproxy-0.2.1.ebuild b/net-misc/igmpproxy/igmpproxy-0.2.1.ebuild
new file mode 100644
index 000000000000..9154819d42db
--- /dev/null
+++ b/net-misc/igmpproxy/igmpproxy-0.2.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info systemd
+
+CONFIG_CHECK="~IP_MULTICAST ~IP_MROUTE"
+
+DESCRIPTION="A multicast routing daemon which uses IGMP forwarding"
+HOMEPAGE="https://github.com/pali/igmpproxy"
+SRC_URI="https://github.com/pali/igmpproxy/releases/download/${PV}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}/igmpproxy.initd" igmpproxy
+ systemd_dounit "${FILESDIR}/${PN}.service"
+
+ newconfd "${FILESDIR}/igmpproxy.confd" igmpproxy
+}