summaryrefslogtreecommitdiff
path: root/net-misc/igmpproxy/igmpproxy-0.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/igmpproxy/igmpproxy-0.1-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/igmpproxy/igmpproxy-0.1-r2.ebuild')
-rw-r--r--net-misc/igmpproxy/igmpproxy-0.1-r2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-misc/igmpproxy/igmpproxy-0.1-r2.ebuild b/net-misc/igmpproxy/igmpproxy-0.1-r2.ebuild
new file mode 100644
index 000000000000..12ba0b99a436
--- /dev/null
+++ b/net-misc/igmpproxy/igmpproxy-0.1-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit linux-info systemd
+
+DESCRIPTION="Multicast Routing Daemon using only IGMP signalling"
+HOMEPAGE="https://sourceforge.net/projects/igmpproxy"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 Stanford"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+CONFIG_CHECK="~IP_MULTICAST ~IP_MROUTE"
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ newinitd "${FILESDIR}/${PN}-init.d" ${PN}
+ newconfd "${FILESDIR}/${PN}-conf.d" ${PN}
+ systemd_dounit "${FILESDIR}/${PN}.service"
+}