summaryrefslogtreecommitdiff
path: root/net-misc/ices/ices-2.0.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
commit514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (patch)
tree555c194dbeb0fb2ac4ad3cde7c0f6a80fd330ce2 /net-misc/ices/ices-2.0.2-r1.ebuild
parent4df3bf9762850b34cd1ead5c80374d1a0fc3362e (diff)
gentoo resync : 17.07.2021
Diffstat (limited to 'net-misc/ices/ices-2.0.2-r1.ebuild')
-rw-r--r--net-misc/ices/ices-2.0.2-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-misc/ices/ices-2.0.2-r1.ebuild b/net-misc/ices/ices-2.0.2-r1.ebuild
new file mode 100644
index 000000000000..001620dd1b72
--- /dev/null
+++ b/net-misc/ices/ices-2.0.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Icecast OGG streaming client, supports on the fly re-encoding"
+HOMEPAGE="https://icecast.org/ices/"
+SRC_URI="http://downloads.xiph.org/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ppc64 sparc x86"
+
+RDEPEND="
+ acct-group/ices
+ acct-user/ices
+ dev-libs/libxml2
+ >=media-libs/libshout-2
+ >=media-libs/libvorbis-1
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ econf --sysconfdir=/etc/ices2
+}
+
+src_install() {
+ default
+ insinto /etc/ices2
+ doins conf/*.xml
+ docinto html
+ dodoc doc/*.{html,css}
+ newinitd "${FILESDIR}"/ices.initd-r1 ices
+ keepdir /var/log/ices
+ fperms 660 /var/log/ices
+ fowners ices:ices /var/log/ices
+ rm -rf "${D}"/usr/share/ices
+}