summaryrefslogtreecommitdiff
path: root/net-misc/httpie/httpie-3.2.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-17 04:08:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-17 04:08:35 +0100
commit43f85394ba834267589a4e6478ef419d40e22503 (patch)
treeb54082395e0e153c889b6dfe60d580a57992b3e8 /net-misc/httpie/httpie-3.2.1-r2.ebuild
parentc4507bfdfd706b2b1301972490fe88ac3ddbc70e (diff)
gentoo auto-resync : 17:05:2023 - 04:08:35
Diffstat (limited to 'net-misc/httpie/httpie-3.2.1-r2.ebuild')
-rw-r--r--net-misc/httpie/httpie-3.2.1-r2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-misc/httpie/httpie-3.2.1-r2.ebuild b/net-misc/httpie/httpie-3.2.1-r2.ebuild
new file mode 100644
index 000000000000..c28c9e703420
--- /dev/null
+++ b/net-misc/httpie/httpie-3.2.1-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="ssl(+)"
+DISTUTILS_USE_PEP517=setuptools
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Modern command line HTTP client"
+HOMEPAGE="https://httpie.io/ https://pypi.org/project/httpie/"
+SRC_URI="https://github.com/httpie/httpie/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/charset_normalizer[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/multidict[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.22.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.9.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-urllib3-2-fixes.patch"
+)
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ newbashcomp extras/httpie-completion.bash http
+ insinto /usr/share/fish/vendor_completions.d
+ newins extras/httpie-completion.fish http.fish
+ distutils-r1_python_install_all
+}