summaryrefslogtreecommitdiff
path: root/net-misc/httpie/httpie-3.2.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-24 03:46:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-24 03:46:27 +0000
commit58177544118b9a8393d7501ee5e0e35cd32f2ad4 (patch)
tree050a5a81c15bb828e5b6fb18d1386aa35673c416 /net-misc/httpie/httpie-3.2.1-r1.ebuild
parent0530006d7f63d6c158b4ff5ea0c3f7ef3bae9cc4 (diff)
gentoo auto-resync : 24:02:2023 - 03:46:27
Diffstat (limited to 'net-misc/httpie/httpie-3.2.1-r1.ebuild')
-rw-r--r--net-misc/httpie/httpie-3.2.1-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-misc/httpie/httpie-3.2.1-r1.ebuild b/net-misc/httpie/httpie-3.2.1-r1.ebuild
new file mode 100644
index 000000000000..b24ab5442eee
--- /dev/null
+++ b/net-misc/httpie/httpie-3.2.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="ssl(+)"
+DISTUTILS_USE_PEP517=setuptools
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Modern command line HTTP client"
+HOMEPAGE="https://httpie.io/ https://pypi.org/project/httpie/"
+SRC_URI="https://github.com/httpie/httpie/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/charset_normalizer[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/multidict[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.22.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.9.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ newbashcomp extras/httpie-completion.bash http
+ insinto /usr/share/fish/vendor_completions.d
+ newins extras/httpie-completion.fish http.fish
+ distutils-r1_python_install_all
+}