summaryrefslogtreecommitdiff
path: root/net-misc/httpie/httpie-1.0.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /net-misc/httpie/httpie-1.0.2-r1.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'net-misc/httpie/httpie-1.0.2-r1.ebuild')
-rw-r--r--net-misc/httpie/httpie-1.0.2-r1.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/net-misc/httpie/httpie-1.0.2-r1.ebuild b/net-misc/httpie/httpie-1.0.2-r1.ebuild
deleted file mode 100644
index aac3979a8995..000000000000
--- a/net-misc/httpie/httpie-1.0.2-r1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
-PYTHON_REQ_USE="ssl(+)"
-
-inherit bash-completion-r1 distutils-r1
-
-DESCRIPTION="Modern command line HTTP client"
-HOMEPAGE="https://httpie.org/ https://pypi.org/project/httpie/"
-SRC_URI="https://github.com/jakubroztocil/httpie/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-
-RDEPEND="dev-python/pygments[${PYTHON_USEDEP}]
- >=dev-python/requests-2.19.1[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/pytest-httpbin[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-# Extend list of expected strings in test
-PATCHES=( "${FILESDIR}/${PN}-1.0.2-fix-test_ssl.patch" )
-
-python_test() {
- pytest -vv || die "Tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- newbashcomp extras/httpie-completion.bash http
- insinto /usr/share/fish/vendor_completions.d
- newins extras/httpie-completion.fish http.fish
- distutils-r1_python_install_all
-}