summaryrefslogtreecommitdiff
path: root/net-misc/htpdate/htpdate-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-05 02:06:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-05 02:06:51 +0100
commita5a60a0e01733705770f24a57953bf44ee06467d (patch)
tree5fa8cc0b689bd45faed74f1be3dcd0a64c8df50b /net-misc/htpdate/htpdate-9999.ebuild
parenta87d0d6b8bfa400637c56d3194b22fca5cbd6f9e (diff)
gentoo auto-resync : 05:08:2022 - 02:06:51
Diffstat (limited to 'net-misc/htpdate/htpdate-9999.ebuild')
-rw-r--r--net-misc/htpdate/htpdate-9999.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/net-misc/htpdate/htpdate-9999.ebuild b/net-misc/htpdate/htpdate-9999.ebuild
index 31e1a7d493bf..51cf1b0a1728 100644
--- a/net-misc/htpdate/htpdate-9999.ebuild
+++ b/net-misc/htpdate/htpdate-9999.ebuild
@@ -7,16 +7,17 @@ inherit readme.gentoo-r1 toolchain-funcs
DESCRIPTION="Synchronize local workstation with time offered by remote webservers"
HOMEPAGE="https://www.vervest.org/htp/"
-if [[ "${PV}" == *9999 ]] ; then
+if [[ ${PV} == *9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/twekkel/htpdate"
else
SRC_URI="https://github.com/twekkel/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux"
fi
-IUSE="+ssl"
+
LICENSE="GPL-2"
SLOT="0"
+IUSE="+ssl"
DEPEND="ssl? ( dev-libs/openssl:0= )"
RDEPEND="${DEPEND}"
@@ -27,8 +28,6 @@ RESTRICT="test"
DOC_CONTENTS="If you would like to run htpdate as a daemon, set
appropriate http servers in /etc/conf.d/htpdate!"
-PATCHES=( )
-
src_prepare() {
default
@@ -39,8 +38,10 @@ src_prepare() {
}
src_compile() {
- emake CFLAGS="-Wall ${CFLAGS} ${LDFLAGS}" CC="$(tc-getCC)" \
- $(usex ssl "https" '')
+ emake \
+ CFLAGS="-Wall ${CFLAGS} ${CPPFLAGS} ${LDFLAGS}" \
+ CC="$(tc-getCC)" \
+ $(usev ssl 'https')
}
src_install() {