summaryrefslogtreecommitdiff
path: root/net-misc/hsc/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/hsc/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/hsc/files')
-rw-r--r--net-misc/hsc/files/hsc-1.0b-cflags.patch45
-rw-r--r--net-misc/hsc/files/hsc-1.0b-glibc-2.10.patch12
-rw-r--r--net-misc/hsc/files/hsc-1.0b-nostrip.patch18
-rw-r--r--net-misc/hsc/files/hsc-1.0b-parmake.patch13
4 files changed, 88 insertions, 0 deletions
diff --git a/net-misc/hsc/files/hsc-1.0b-cflags.patch b/net-misc/hsc/files/hsc-1.0b-cflags.patch
new file mode 100644
index 000000000000..1459d5ad049a
--- /dev/null
+++ b/net-misc/hsc/files/hsc-1.0b-cflags.patch
@@ -0,0 +1,45 @@
+Index: hsc-1.0/configure.in
+===================================================================
+--- hsc-1.0.orig/configure.in
++++ hsc-1.0/configure.in
+@@ -46,12 +46,12 @@ case $host in
+ ;;
+ esac
+ echo "Configuring for $SYSTEM"
+-CFLAGS="-Wall -pedantic"
++CFLAGS="$CFLAGS -Wall -pedantic"
+
+ AC_ARG_ENABLE(debug,
+ AS_HELP_STRING([--enable-debug],[Compile programs with GDB support and debugging output]),
+ [CFLAGS="$CFLAGS -ggdb -g3 -DDEBUG"; REGEXDEBUG="regex/printchar.o"],
+- CFLAGS="$CFLAGS -fomit-frame-pointer -Os")
++ CFLAGS="$CFLAGS")
+ AC_ARG_ENABLE(efence,
+ AS_HELP_STRING([--enable-efence],[Link with efence library for memory debugging]),
+ CFLAGS="$CFLAGS -lefence")
+Index: hsc-1.0/src/regex/Makefile.in
+===================================================================
+--- hsc-1.0.orig/src/regex/Makefile.in
++++ hsc-1.0/src/regex/Makefile.in
+@@ -29,7 +29,7 @@ version = 0.12
+ CPPFLAGS =
+
+ # Likewise, you can override CFLAGS to optimize, use -Wall, etc.
+-CFLAGS = -g
++#CFLAGS = -g
+
+ # Ditto for LDFLAGS and LOADLIBES.
+ LDFLAGS =
+Index: hsc-1.0/src/Makefile.in
+===================================================================
+--- hsc-1.0.orig/src/Makefile.in
++++ hsc-1.0/src/Makefile.in
+@@ -27,7 +27,7 @@ DATADIR=@datadir@
+
+ CFLAGS = @CFLAGS@ -D@SYSTEM@ -I.
+ COMP = @CC@ -o $@ $(CFLAGS)
+-LINK = @CC@ -o $@ $(CFLAGS)
++LINK = @CC@ -o $@ $(CFLAGS) $(LDFLAGS)
+ LINKLIBS= @LINKLIBS@
+ MOVE = mv
+ COPY = cp
diff --git a/net-misc/hsc/files/hsc-1.0b-glibc-2.10.patch b/net-misc/hsc/files/hsc-1.0b-glibc-2.10.patch
new file mode 100644
index 000000000000..5c10efc0f9a2
--- /dev/null
+++ b/net-misc/hsc/files/hsc-1.0b-glibc-2.10.patch
@@ -0,0 +1,12 @@
+diff -ur hsc-1.0.orig/src/hsclib/css.c hsc-1.0/src/hsclib/css.c
+--- hsc-1.0.orig/src/hsclib/css.c 2006-04-03 17:18:37.000000000 +0300
++++ hsc-1.0/src/hsclib/css.c 2009-08-09 20:19:51.000000000 +0300
+@@ -129,7 +129,7 @@
+ #ifdef isblank
+ #undef isblank
+ #endif
+-static int isblank(int c)
++int isblank(int c)
+ {
+ return ((c == ' ') || (c == '\t'));
+ }
diff --git a/net-misc/hsc/files/hsc-1.0b-nostrip.patch b/net-misc/hsc/files/hsc-1.0b-nostrip.patch
new file mode 100644
index 000000000000..af4cc947d8fd
--- /dev/null
+++ b/net-misc/hsc/files/hsc-1.0b-nostrip.patch
@@ -0,0 +1,18 @@
+Index: hsc-1.0/src/Makefile.in
+===================================================================
+--- hsc-1.0.orig/src/Makefile.in
++++ hsc-1.0/src/Makefile.in
+@@ -87,10 +87,9 @@ rex:
+ # installation
+ #--------------------------------------------------------------------
+ install : all
+- strip $(EXE_ALL)
+- $(INSTALL) -Ds hsc/hsc $(BINDIR)/hsc
+- $(INSTALL) -Ds hsctools/hscdepp $(BINDIR)/hscdepp
+- $(INSTALL) -Ds hsctools/hscpitt $(BINDIR)/hscpitt
++ $(INSTALL) -D hsc/hsc $(BINDIR)/hsc
++ $(INSTALL) -D hsctools/hscdepp $(BINDIR)/hscdepp
++ $(INSTALL) -D hsctools/hscpitt $(BINDIR)/hscpitt
+
+ #--------------------------------------------------------------------
+ # cleanup - remove all objects and executables
diff --git a/net-misc/hsc/files/hsc-1.0b-parmake.patch b/net-misc/hsc/files/hsc-1.0b-parmake.patch
new file mode 100644
index 000000000000..8c93d32f4888
--- /dev/null
+++ b/net-misc/hsc/files/hsc-1.0b-parmake.patch
@@ -0,0 +1,13 @@
+Index: hsc-1.0/Makefile.in
+===================================================================
+--- hsc-1.0.orig/Makefile.in
++++ hsc-1.0/Makefile.in
+@@ -30,7 +30,7 @@ all: hsc docs
+
+ hsc:
+ make -C src
+-docs:
++docs: hsc
+ PATH="$(shell pwd)/src/hsc:$(PATH)" HSCEXTRAOPTS="IGNORE=21" make -C docs-source
+
+ install: