summaryrefslogtreecommitdiff
path: root/net-misc/gwhois/gwhois-20120626.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/gwhois/gwhois-20120626.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/gwhois/gwhois-20120626.ebuild')
-rw-r--r--net-misc/gwhois/gwhois-20120626.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-misc/gwhois/gwhois-20120626.ebuild b/net-misc/gwhois/gwhois-20120626.ebuild
new file mode 100644
index 000000000000..dea737cfdd30
--- /dev/null
+++ b/net-misc/gwhois/gwhois-20120626.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils
+
+MY_P=${P/_p/.}
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="generic whois"
+HOMEPAGE="http://gwhois.de/"
+SRC_URI="http://gwhois.de/gwhois/${MY_P/-/_}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="www-client/lynx
+ net-misc/curl
+ dev-lang/perl
+ dev-perl/libwww-perl
+ dev-perl/Net-LibIDN"
+
+src_install() {
+ dodir /etc/gwhois
+ insinto /etc/gwhois
+ doins pattern
+ dobin gwhois
+ doman gwhois.1
+ dodoc TODO "${FILESDIR}/gwhois.xinetd" README.RIPE
+ einfo ""
+ einfo "See included gwhois.xinetd for an example on how to"
+ einfo "use gwhois as a whois proxy using xinetd."
+ einfo "Just copy gwhois.xinetd to /etc/xinetd.d/gwhois"
+ einfo "and reload xinetd."
+ einfo ""
+}
+
+pkg_postinst() {
+ if [ -f /etc/gwhois/pattern.ripe ]; then
+ ewarn ""
+ ewarn "Will move old /etc/gwhois/pattern.ripe to removethis-pattern.ripe"
+ ewarn "as it causes malfunction with this version."
+ ewarn "If you did not modify the file, just remove it."
+ ewarn ""
+ mv /etc/gwhois/pattern.ripe /etc/gwhois/removethis-pattern.ripe
+ fi
+}