summaryrefslogtreecommitdiff
path: root/net-misc/gwhois/gwhois-20120626-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-31 16:00:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-31 16:00:27 +0000
commit1db00cc6e94b90c08090bb5b8c406622946c4ae5 (patch)
treec34bf820c2809fb7e08ed5564df2a25cf759516f /net-misc/gwhois/gwhois-20120626-r1.ebuild
parent693cc9b6e847a01c1bb692153021aaf9fb0fab25 (diff)
gentoo resync 31.01.2019
Diffstat (limited to 'net-misc/gwhois/gwhois-20120626-r1.ebuild')
-rw-r--r--net-misc/gwhois/gwhois-20120626-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/net-misc/gwhois/gwhois-20120626-r1.ebuild b/net-misc/gwhois/gwhois-20120626-r1.ebuild
new file mode 100644
index 000000000000..3ff907bae8cb
--- /dev/null
+++ b/net-misc/gwhois/gwhois-20120626-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit readme.gentoo-r1
+
+MY_P="${P/_p/.}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Generic whois"
+HOMEPAGE="https://julijane.de/gwhois/"
+# Debian is still maintaining it
+#SRC_URI="http://gwhois.de/gwhois/${MY_P/-/_}.tar.gz"
+
+DEBIAN_VER="1.2"
+SRC_URI="mirror://debian/pool/main/g/${PN}/${MY_P/-/_}-${DEBIAN_VER}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ www-client/lynx
+ net-misc/curl
+ dev-lang/perl:=
+ dev-perl/libwww-perl
+ dev-perl/Net-LibIDN
+"
+DEPEND=""
+
+DOC_CONTENTS="
+ See included gwhois.xinetd for an example on how to
+ use gwhois as a whois proxy using xinetd.
+ Just copy gwhois.xinetd to /etc/xinetd.d/gwhois
+ and reload xinetd.
+"
+
+src_install() {
+ dodir /etc/gwhois
+ insinto /etc/gwhois
+ doins pattern
+ dobin gwhois
+ doman gwhois.1
+ dodoc TODO "${FILESDIR}/gwhois.xinetd" README.RIPE
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ if [ -f /etc/gwhois/pattern.ripe ]; then
+ ewarn ""
+ ewarn "Will move old /etc/gwhois/pattern.ripe to removethis-pattern.ripe"
+ ewarn "as it causes malfunction with this version."
+ ewarn "If you did not modify the file, just remove it."
+ ewarn ""
+ mv /etc/gwhois/pattern.ripe /etc/gwhois/removethis-pattern.ripe
+ fi
+ readme.gentoo_print_elog
+}