summaryrefslogtreecommitdiff
path: root/net-misc/grive/grive-0.5.1_pre20171005.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
commitbd7908c6630f38067350d396ac5d18c3cc2434a0 (patch)
tree3559b3e11424f5529527f2474d8a977a91ee3389 /net-misc/grive/grive-0.5.1_pre20171005.ebuild
parent8b2628ad8526c806375e7b157889e4274b70248b (diff)
gentoo resync : 29.10.2017
Diffstat (limited to 'net-misc/grive/grive-0.5.1_pre20171005.ebuild')
-rw-r--r--net-misc/grive/grive-0.5.1_pre20171005.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/grive/grive-0.5.1_pre20171005.ebuild b/net-misc/grive/grive-0.5.1_pre20171005.ebuild
new file mode 100644
index 000000000000..744cc461a623
--- /dev/null
+++ b/net-misc/grive/grive-0.5.1_pre20171005.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-utils
+
+if [[ ${PV} = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vitalif/${PN}2.git"
+else
+ inherit vcs-snapshot
+ COMMIT="3c90425b8f46b62365ec3d84de628163865dbb1e"
+ SRC_URI="https://github.com/vitalif/${PN}2/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="An open source Linux client for Google Drive"
+HOMEPAGE="https://github.com/vitalif/grive2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/expat
+ >=dev-libs/json-c-0.11-r1:=
+ dev-libs/libgcrypt:0=
+ || ( net-misc/curl[curl_ssl_openssl] net-misc/curl[curl_ssl_gnutls] )
+ sys-libs/binutils-libs:0=
+ sys-libs/glibc
+ dev-libs/yajl
+"
+DEPEND="${RDEPEND}"