summaryrefslogtreecommitdiff
path: root/net-misc/grive/grive-0.5.1_pre20161004.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/grive/grive-0.5.1_pre20161004.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/grive/grive-0.5.1_pre20161004.ebuild')
-rw-r--r--net-misc/grive/grive-0.5.1_pre20161004.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/grive/grive-0.5.1_pre20161004.ebuild b/net-misc/grive/grive-0.5.1_pre20161004.ebuild
new file mode 100644
index 000000000000..5990f75e9ceb
--- /dev/null
+++ b/net-misc/grive/grive-0.5.1_pre20161004.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-utils
+
+if [[ ${PV} = *9999 ]]; then
+ inherit git-2
+ EGIT_REPO_URI="https://github.com/vitalif/${PN}2.git"
+else
+ inherit vcs-snapshot
+ COMMIT="7bbb01c3014cc996ec24a7e5c0684f24b604b735"
+ SRC_URI="https://github.com/vitalif/${PN}2/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="An open source Linux client for Google Drive"
+HOMEPAGE="https://github.com/vitalif/grive2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/expat
+ >=dev-libs/json-c-0.11-r1:=
+ dev-libs/libgcrypt:0=
+ || ( net-misc/curl[curl_ssl_openssl] net-misc/curl[curl_ssl_gnutls] )
+ sys-libs/binutils-libs:0=
+ sys-libs/glibc
+ dev-libs/yajl
+"
+DEPEND="${RDEPEND}"