summaryrefslogtreecommitdiff
path: root/net-misc/grdesktop/grdesktop-0.23-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/grdesktop/grdesktop-0.23-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/grdesktop/grdesktop-0.23-r1.ebuild')
-rw-r--r--net-misc/grdesktop/grdesktop-0.23-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-misc/grdesktop/grdesktop-0.23-r1.ebuild b/net-misc/grdesktop/grdesktop-0.23-r1.ebuild
new file mode 100644
index 000000000000..39b0acec73ce
--- /dev/null
+++ b/net-misc/grdesktop/grdesktop-0.23-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="Gtk2 frontend for rdesktop"
+HOMEPAGE="http://www.nongnu.org/grdesktop/"
+SRC_URI="https://savannah.nongnu.org/download/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="
+ x11-libs/gtk+:2
+ >=gnome-base/libgnomeui-2
+ net-misc/rdesktop
+ gnome-base/gconf:2
+"
+DEPEND="${RDEPEND}
+ app-text/rarian
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Correct icon path. See bug #50295.
+ eapply "${FILESDIR}/${P}-desktop.patch"
+
+ # Fix compilation with format-security, bug #517662
+ eapply "${FILESDIR}/${P}-format-security.patch"
+
+ sed -e 's/\(GETTEXT_PACKAGE = \)@GETTEXT_PACKAGE@/\1grdesktop/g' \
+ -i po/Makefile.in.in || die "sed 2 failed"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-debug \
+ --with-keymap-path=/usr/share/rdesktop/keymaps/
+}