summaryrefslogtreecommitdiff
path: root/net-misc/gofish/gofish-1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/gofish/gofish-1.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/gofish/gofish-1.2.ebuild')
-rw-r--r--net-misc/gofish/gofish-1.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/gofish/gofish-1.2.ebuild b/net-misc/gofish/gofish-1.2.ebuild
new file mode 100644
index 000000000000..68b0fe7e5df9
--- /dev/null
+++ b/net-misc/gofish/gofish-1.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=2
+
+inherit eutils user
+
+DESCRIPTION="Gofish gopher server"
+HOMEPAGE="http://gofish.sourceforge.net"
+SRC_URI="mirror://sourceforge/gofish/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ enewgroup gopher
+ enewuser gopher -1 -1 -1 gopher
+}
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --disable-mmap-cache || die
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die
+
+ newinitd "${FILESDIR}"/gofish.rc gofish || die
+ newconfd "${FILESDIR}"/gofish.confd gofish || die
+
+ dodoc AUTHORS ChangeLog Configure_GoFish README TODO || die
+}