summaryrefslogtreecommitdiff
path: root/net-misc/gofish/gofish-1.2-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-29 23:15:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-29 23:15:57 +0100
commit2ebceb686e2370a0a9172a7be4a3c29555a08b80 (patch)
treeda445d4418a55d8e05bfb6d709fb65ac3eca9daa /net-misc/gofish/gofish-1.2-r2.ebuild
parente169149b84bc9ff33d3286d60dfab754d2e0e4be (diff)
gentoo auto-resync : 29:04:2023 - 23:15:57
Diffstat (limited to 'net-misc/gofish/gofish-1.2-r2.ebuild')
-rw-r--r--net-misc/gofish/gofish-1.2-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-misc/gofish/gofish-1.2-r2.ebuild b/net-misc/gofish/gofish-1.2-r2.ebuild
new file mode 100644
index 000000000000..c23940d7517e
--- /dev/null
+++ b/net-misc/gofish/gofish-1.2-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Gofish gopher server"
+HOMEPAGE="http://gofish.sourceforge.net"
+SRC_URI="mirror://sourceforge/gofish/${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~x86"
+
+# See bug #905314 for bsd-games blocker.
+RDEPEND="
+ acct-group/gopher
+ acct-user/gopher
+ !games-misc/bsd-games
+"
+
+DOCS=( Configure_GoFish )
+
+src_configure() {
+ local myeconfargs=(
+ --localstatedir=/var
+ --disable-mmap-cache
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}"/gofish-1.2-r1.rc gofish
+ newconfd "${FILESDIR}"/gofish-1.2-r1.confd gofish
+}