summaryrefslogtreecommitdiff
path: root/net-misc/gofish/gofish-1.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /net-misc/gofish/gofish-1.2-r1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'net-misc/gofish/gofish-1.2-r1.ebuild')
-rw-r--r--net-misc/gofish/gofish-1.2-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/gofish/gofish-1.2-r1.ebuild b/net-misc/gofish/gofish-1.2-r1.ebuild
new file mode 100644
index 000000000000..fa82bccbe174
--- /dev/null
+++ b/net-misc/gofish/gofish-1.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Gofish gopher server"
+HOMEPAGE="http://gofish.sourceforge.net"
+SRC_URI="mirror://sourceforge/gofish/${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ acct-group/gopher
+ acct-user/gopher
+"
+
+DOCS=( Configure_GoFish )
+
+src_configure() {
+ local myeconfargs=(
+ --localstatedir=/var
+ --disable-mmap-cache
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}"/gofish-1.2-r1.rc gofish
+ newconfd "${FILESDIR}"/gofish-1.2-r1.confd gofish
+}