summaryrefslogtreecommitdiff
path: root/net-misc/gallery-dl/gallery-dl-1.26.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-10 23:14:41 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-10 23:14:41 +0000
commit145b1805c3986974378af5c60767504ecc9ed280 (patch)
tree28dbd5be73a5af5dd20d4ea81d293394d975c9e0 /net-misc/gallery-dl/gallery-dl-1.26.4.ebuild
parent627302fc2f41a621644260ffa3f50e06ea5edd60 (diff)
gentoo auto-resync : 10:12:2023 - 23:14:40
Diffstat (limited to 'net-misc/gallery-dl/gallery-dl-1.26.4.ebuild')
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.26.4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/gallery-dl/gallery-dl-1.26.4.ebuild b/net-misc/gallery-dl/gallery-dl-1.26.4.ebuild
new file mode 100644
index 000000000000..b3da2a9c870f
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-1.26.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite,ssl,xml(+)"
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download image galleries and collections from several image hosting sites"
+HOMEPAGE="https://github.com/mikf/gallery-dl"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
+else
+ SRC_URI="https://github.com/mikf/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+# Tests require network access.
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND=">=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py
+
+python_compile_all() {
+ emake PYTHON=${EPYTHON} data/completion/{,_}gallery-dl man
+}
+
+pkg_postinst() {
+ optfeature "Pixiv Ugoira to WebM conversion" media-video/ffmpeg
+ optfeature "video downloads" net-misc/yt-dlp
+}