summaryrefslogtreecommitdiff
path: root/net-misc/freerdp/freerdp-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-17 18:49:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-17 18:49:32 +0000
commit5c94a4b3d11ad7b169e23bd604cf403c96bf4f1c (patch)
tree51700ddb4327326dcc3f915423b58b3842fef379 /net-misc/freerdp/freerdp-9999.ebuild
parentd1ad4013179c639433bdbfa5025ca403aac0767b (diff)
gentoo auto-resync : 17:03:2024 - 18:49:32
Diffstat (limited to 'net-misc/freerdp/freerdp-9999.ebuild')
-rw-r--r--net-misc/freerdp/freerdp-9999.ebuild106
1 files changed, 66 insertions, 40 deletions
diff --git a/net-misc/freerdp/freerdp-9999.ebuild b/net-misc/freerdp/freerdp-9999.ebuild
index 82b1a427b285..1821299544d6 100644
--- a/net-misc/freerdp/freerdp-9999.ebuild
+++ b/net-misc/freerdp/freerdp-9999.ebuild
@@ -22,11 +22,16 @@ DESCRIPTION="Free implementation of the Remote Desktop Protocol"
HOMEPAGE="https://www.freerdp.com/"
LICENSE="Apache-2.0"
-SLOT="0/3"
-IUSE="aad alsa cpu_flags_arm_neon cups debug +ffmpeg +fuse gstreamer +icu jpeg kerberos openh264 pulseaudio sdl server smartcard systemd test usb valgrind wayland X xinerama xv"
+SLOT="3"
+IUSE="aad alsa cpu_flags_arm_neon +client cups debug +ffmpeg +fuse gstreamer +icu jpeg kerberos openh264 pulseaudio sdl server smartcard systemd test +tools usb valgrind wayland X xinerama xv"
RESTRICT="!test? ( test )"
-RDEPEND="
+BDEPEND="
+ virtual/pkgconfig
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+"
+COMMON_DEPEND="
dev-libs/openssl:0=
sys-libs/zlib:0
aad? ( dev-libs/cJSON )
@@ -81,25 +86,39 @@ RDEPEND="
sys-apps/pcsc-lite
)
systemd? ( sys-apps/systemd:0= )
- wayland? (
- dev-libs/wayland
- x11-libs/libxkbcommon
+ client? (
+ wayland? (
+ dev-libs/wayland
+ x11-libs/libxkbcommon
+ )
)
X? (
x11-libs/libX11
x11-libs/libxkbfile
)
"
-DEPEND="
- ${RDEPEND}
+DEPEND="${COMMON_DEPEND}
valgrind? ( dev-debug/valgrind )
"
-BDEPEND="
- virtual/pkgconfig
- app-text/docbook-xsl-stylesheets
- dev-libs/libxslt
+RDPEND="${COMMON_DEPEND}
+ !net-misc/freerdp:0
+ client? ( !net-misc/freerdp:2[client] )
+ server? ( !net-misc/freerdp:2[server] )
+ tools? ( !net-misc/freerdp:2[tools] )
"
+option() {
+ usex "$1" ON OFF
+}
+
+option_client() {
+ if use client; then
+ option "$1"
+ else
+ echo OFF
+ fi
+}
+
src_configure() {
# bug #881695
filter-lto
@@ -110,40 +129,42 @@ src_configure() {
# https://bugs.gentoo.org/927037
-DCMAKE_INTERPROCEDURAL_OPTIMIZATION=OFF
- -DBUILD_TESTING=$(usex test ON OFF)
- -DCHANNEL_URBDRC=$(usex usb ON OFF)
- -DWITH_AAD=$(usex aad ON OFF)
- -DWITH_ALSA=$(usex alsa ON OFF)
+ -DBUILD_TESTING=$(option test)
+ -DCHANNEL_URBDRC=$(option usb)
+ -DWITH_AAD=$(option aad)
+ -DWITH_ALSA=$(option alsa)
-DWITH_CCACHE=OFF
- -DWITH_CLIENT_SDL=$(usex sdl ON OFF)
+ -DWITH_CLIENT=$(option client)
+ -DWITH_CLIENT_SDL=$(option sdl)
-DWITH_SAMPLE=OFF
- -DWITH_CUPS=$(usex cups ON OFF)
- -DWITH_DEBUG_ALL=$(usex debug ON OFF)
+ -DWITH_CUPS=$(option cups)
+ -DWITH_DEBUG_ALL=$(option debug)
-DWITH_MANPAGES=ON
- -DWITH_FFMPEG=$(usex ffmpeg ON OFF)
+ -DWITH_FFMPEG=$(option ffmpeg)
-DWITH_FREERDP_DEPRECATED_COMMANDLINE=ON
- -DWITH_SWSCALE=$(usex ffmpeg ON OFF)
- -DWITH_CAIRO=$(usex ffmpeg OFF ON)
- -DWITH_DSP_FFMPEG=$(usex ffmpeg ON OFF)
- -DWITH_FUSE=$(usex fuse ON OFF)
- -DWITH_GSTREAMER_1_0=$(usex gstreamer ON OFF)
- -DWITH_JPEG=$(usex jpeg ON OFF)
- -DWITH_KRB5=$(usex kerberos ON OFF)
- -DWITH_NEON=$(usex cpu_flags_arm_neon ON OFF)
- -DWITH_OPENH264=$(usex openh264 ON OFF)
+ -DWITH_SWSCALE=$(option ffmpeg)
+ -DWITH_CAIRO=$(option !ffmpeg)
+ -DWITH_DSP_FFMPEG=$(option ffmpeg)
+ -DWITH_FUSE=$(option fuse)
+ -DWITH_GSTREAMER_1_0=$(option gstreamer)
+ -DWITH_JPEG=$(option jpeg)
+ -DWITH_KRB5=$(option kerberos)
+ -DWITH_NEON=$(option cpu_flags_arm_neon)
+ -DWITH_OPENH264=$(option openh264)
-DWITH_OSS=OFF
- -DWITH_PCSC=$(usex smartcard ON OFF)
- -DWITH_PKCS11=$(usex smartcard ON OFF)
- -DWITH_PULSE=$(usex pulseaudio ON OFF)
- -DWITH_SERVER=$(usex server ON OFF)
- -DWITH_LIBSYSTEMD=$(usex systemd ON OFF)
- -DWITH_UNICODE_BUILTIN=$(usex icu OFF ON)
- -DWITH_VALGRIND_MEMCHECK=$(usex valgrind ON OFF)
- -DWITH_X11=$(usex X ON OFF)
- -DWITH_XINERAMA=$(usex xinerama ON OFF)
- -DWITH_XV=$(usex xv ON OFF)
- -DWITH_WAYLAND=$(usex wayland ON OFF)
+ -DWITH_PCSC=$(option smartcard)
+ -DWITH_PKCS11=$(option smartcard)
+ -DWITH_PULSE=$(option pulseaudio)
+ -DWITH_SERVER=$(option server)
+ -DWITH_LIBSYSTEMD=$(option systemd)
+ -DWITH_UNICODE_BUILTIN=$(option !icu)
+ -DWITH_VALGRIND_MEMCHECK=$(option valgrind)
+ -DWITH_X11=$(option X)
+ -DWITH_XINERAMA=$(option xinerama)
+ -DWITH_XV=$(option xv)
+ -DWITH_WAYLAND=$(option_client wayland)
-DWITH_WEBVIEW=OFF
+ -DWITH_WINPR_TOOLS=$(option tools)
)
cmake_src_configure
}
@@ -154,3 +175,8 @@ src_test() {
has network-sandbox ${FEATURES} && myctestargs+=( -E TestConnect )
cmake_src_test
}
+
+src_install() {
+ cmake_src_install
+ mv "${ED}"/usr/share/man/man7/wlog{,3}.7 || die
+}