summaryrefslogtreecommitdiff
path: root/net-misc/exabgp/exabgp-4.2.21.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-19 02:37:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-19 02:37:55 +0100
commitb5c8e7977a8950fe976559fbed28db9c0bcd3d6f (patch)
treef3685b9d72ea7daa9be01003ad1168de69152385 /net-misc/exabgp/exabgp-4.2.21.ebuild
parente26a7b5ef1fe42a66a3c91fe878da93c7cf83737 (diff)
gentoo auto-resync : 19:07:2022 - 02:37:54
Diffstat (limited to 'net-misc/exabgp/exabgp-4.2.21.ebuild')
-rw-r--r--net-misc/exabgp/exabgp-4.2.21.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/net-misc/exabgp/exabgp-4.2.21.ebuild b/net-misc/exabgp/exabgp-4.2.21.ebuild
new file mode 100644
index 000000000000..2bd1bad24a9e
--- /dev/null
+++ b/net-misc/exabgp/exabgp-4.2.21.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit tmpfiles systemd distutils-r1
+
+DESCRIPTION="The BGP swiss army knife of networking"
+HOMEPAGE="https://github.com/Exa-Networks/exabgp"
+SRC_URI="https://github.com/Exa-Networks/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ acct-group/exabgp
+ acct-user/exabgp
+"
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/exabgp-4.2.7-paths.patch"
+ "${FILESDIR}/exabgp-4.2.10-ip-path.patch"
+ "${FILESDIR}/exabgp-4.2.11-healthcheck-allow-disable-metric.patch"
+ "${FILESDIR}/exabgp-4.2.11-healthcheck-fix-log-crash.patch"
+ "${FILESDIR}/exabgp-4.2.11-less-verbose-logging.patch"
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ ./qa/bin/parsing || die "tests fail with ${EPYTHON}"
+ epytest
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ newinitd "${FILESDIR}/${PN}.initd-r2" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+ newtmpfiles "${FILESDIR}/exabgp.tmpfiles" ${PN}.conf
+ systemd_dounit etc/systemd/*
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotate" ${PN}
+
+ keepdir /etc/exabgp
+
+ doman doc/man/*.?
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+}