summaryrefslogtreecommitdiff
path: root/net-misc/eventd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-misc/eventd
reinit the tree, so we can have metadata
Diffstat (limited to 'net-misc/eventd')
-rw-r--r--net-misc/eventd/Manifest5
-rw-r--r--net-misc/eventd/eventd-0.21.0.ebuild120
-rw-r--r--net-misc/eventd/eventd-0.23.0.ebuild135
-rw-r--r--net-misc/eventd/metadata.xml24
4 files changed, 284 insertions, 0 deletions
diff --git a/net-misc/eventd/Manifest b/net-misc/eventd/Manifest
new file mode 100644
index 000000000000..ead2063f04f0
--- /dev/null
+++ b/net-misc/eventd/Manifest
@@ -0,0 +1,5 @@
+DIST eventd-0.21.0.tar.xz 392080 SHA256 f4e1bf014e3e17bf79d3b2a61d947cf4d34000d35fab0b90b869f33f002d2349 SHA512 5907d453c493c9f2332df506037027ef7df021b1e29a6773cf8bb5c32c7a301b65ca55d3e3ea40982d3e48b837738c97b5420309a45a550f409d8912636d1dae WHIRLPOOL 864221209a50491aa9d631ff4b8d9f28b1cda77c6c34b5ac597f0496312830ae75bf10166a574df5adcd93b062fa711f79bcabb8b74e7ca254b40c99b1cb373c
+DIST eventd-0.23.0.tar.xz 157468 SHA256 fe4905d79c8312686c11db28783364b84216289fd1a7fa58db3137135047dc9e SHA512 3aba3e6c969fd123420935537b504ee3868ae1bb2589c1a755228a3aaf010fb71720a708e20de9de7a006cce9094a2b549c5eb686575f6b5b7a772e523b778c6 WHIRLPOOL 56807be1e2c52dd0fee24e815e601dd0ca11c7bdc2d5d3a3e7bdf8ecdf1d090438bf106135de411d788d3eada47dd4f1d5137665c26a5194a164f5d1ae649003
+EBUILD eventd-0.21.0.ebuild 2966 SHA256 74772e2b924fae4400c134ebd7ec616de57c5401ccf68793a73609d9d3f1706a SHA512 c01234e76c5d57a059da82843a3cfd33c088723432e4964a23440c7ab5276755a7e159a23bf10a736e999e7c0566a8d87dd751b58b7112cf19b5abebe5e032a1 WHIRLPOOL 5f42a7c7b5cc8de5724458e4b67271c035588ef7418a2526cc334e450bb59463780ffe30a1e3234e99f69f31d8ce04c72240f05e7707d7d2bd34077b78a94acc
+EBUILD eventd-0.23.0.ebuild 3437 SHA256 019bb71068ae49ec030a76ca4c8785ebb001c0fa880fb09dff34c79e9de3c7ec SHA512 3d8b65b2cab267a18aaf5e1e49b14225a5bdb9ff153d920aae802025478547d40a2c4f0d791ae2c2292a2b290bba93f828afc41db03e801fa648a208c94d55fc WHIRLPOOL 91a59a6c6a54bffddd9edbe9e1fe9b597d4d1e5678ff064e0c215061994800975210cffa331fbc3e396857dca3e7b6f0a56eae6812a2530a3bea59c6fe0489d1
+MISC metadata.xml 1025 SHA256 0808be888d72f12b8bd8fd2775d1ca42d3902a8d75e1a7c5328f15dfa40deee7 SHA512 9cb34b13668a902ce4bb7748245a7c254d52246e4df047fa0ce4de5ae9625fe0f83566394116dd99c638953786d84bfa40dd20144e2f87bf26c518c1be615e8b WHIRLPOOL d42e5b532a6f96c1a2f748e374e57831fbc02347a75f5771883728d0eb907b32e98ee8f9f61fdb052c2d39d92d52c2ac99b454883911ba792639978d1a30de4f
diff --git a/net-misc/eventd/eventd-0.21.0.ebuild b/net-misc/eventd/eventd-0.21.0.ebuild
new file mode 100644
index 000000000000..e367b620f030
--- /dev/null
+++ b/net-misc/eventd/eventd-0.21.0.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info systemd xdg-utils
+
+DESCRIPTION="A small daemon to act on remote or local events"
+HOMEPAGE="https://www.eventd.org/"
+SRC_URI="https://www.eventd.org/download/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3+ LGPL-3+ MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug fbcon +introspection ipv6 libcanberra libnotify +notification
+ pulseaudio purple speech systemd test upnp websocket +X zeroconf"
+
+REQUIRED_USE="
+ X? ( notification )
+ fbcon? ( notification )
+ notification? ( || ( X fbcon ) )
+"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.40:2
+ sys-apps/util-linux
+ introspection? ( >=dev-libs/gobject-introspection-1.42 )
+ libcanberra? ( media-libs/libcanberra )
+ libnotify? ( x11-libs/gdk-pixbuf:2 )
+ notification? (
+ x11-libs/cairo
+ x11-libs/pango
+ x11-libs/gdk-pixbuf:2
+ X? (
+ x11-libs/cairo[xcb]
+ x11-libs/libxcb:=
+ x11-libs/xcb-util
+ x11-libs/xcb-util-wm
+ )
+ )
+ pulseaudio? (
+ media-libs/libsndfile
+ media-sound/pulseaudio
+ )
+ purple? ( net-im/pidgin )
+ speech? ( app-accessibility/speech-dispatcher )
+ systemd? ( sys-apps/systemd:= )
+ upnp? ( net-libs/gssdp:= )
+ websocket? ( >=net-libs/libsoup-2.50:2.4 )
+ zeroconf? ( net-dns/avahi[dbus] )
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.5
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ virtual/pkgconfig
+ fbcon? ( virtual/os-headers )
+"
+RDEPEND="${COMMON_DEPEND}
+ net-libs/glib-networking[ssl]
+"
+
+pkg_setup() {
+ if use ipv6; then
+ CONFIG_CHECK=$(usex test 'IPV6' '~IPV6')
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ default_src_prepare
+
+ # Workaround Gentoo bug 604398.
+ sed -i \
+ -e 's|libspeechd|speech-dispatcher/libspeechd|g' \
+ plugins/tts/src/tts.c || die
+
+ # Prevent access violations from introspection metadata generation.
+ xdg_environment_reset
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ --with-dbussessionservicedir="${EPREFIX}/usr/share/dbus-1/services"
+ $(use_enable websocket)
+ $(use_enable zeroconf dns-sd)
+ $(use_enable upnp ssdp)
+ $(use_enable introspection)
+ $(use_enable ipv6)
+ $(use_enable systemd)
+ $(use_enable notification notification-daemon)
+ # Wayland plugin requires wayland-wall, which is currently WIP.
+ # See https://github.com/wayland-wall/wayland-wall/issues/1
+ --disable-nd-wayland
+ $(use_enable X nd-xcb)
+ $(use_enable fbcon nd-fbdev)
+ $(use_enable purple im)
+ $(use_enable pulseaudio sound)
+ $(use_enable speech tts)
+ $(use_enable libnotify)
+ $(use_enable libcanberra)
+ $(use_enable debug)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ local -x EVENTD_TESTS_TMP_DIR="${T}"
+ default_src_test
+}
+
+pkg_postinst() {
+ if { use notification || use libnotify; } && ! has_version 'gnome-base/librsvg'; then
+ elog
+ elog "For SVG icons in notifications, please install 'gnome-base/librsvg'."
+ elog
+ fi
+}
diff --git a/net-misc/eventd/eventd-0.23.0.ebuild b/net-misc/eventd/eventd-0.23.0.ebuild
new file mode 100644
index 000000000000..c656458a7962
--- /dev/null
+++ b/net-misc/eventd/eventd-0.23.0.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic linux-info meson systemd xdg-utils
+
+DESCRIPTION="A small daemon to act on remote or local events"
+HOMEPAGE="https://www.eventd.org/"
+SRC_URI="https://www.eventd.org/download/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3+ LGPL-3+ MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug fbcon +introspection ipv6 libcanberra libnotify +notification
+ pulseaudio purple speech systemd test upnp websocket +X zeroconf"
+
+REQUIRED_USE="
+ X? ( notification )
+ fbcon? ( notification )
+ notification? ( || ( X fbcon ) )
+ test? ( websocket )
+"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.40:2
+ sys-apps/util-linux
+ introspection? ( >=dev-libs/gobject-introspection-1.42 )
+ libcanberra? ( media-libs/libcanberra )
+ libnotify? ( x11-libs/gdk-pixbuf:2 )
+ notification? (
+ x11-libs/cairo
+ x11-libs/pango
+ x11-libs/gdk-pixbuf:2
+ X? (
+ x11-libs/cairo[xcb]
+ x11-libs/libxcb:=
+ x11-libs/xcb-util
+ x11-libs/xcb-util-wm
+ )
+ )
+ pulseaudio? (
+ media-libs/libsndfile
+ media-sound/pulseaudio
+ )
+ purple? ( net-im/pidgin )
+ speech? ( app-accessibility/speech-dispatcher )
+ systemd? ( sys-apps/systemd:= )
+ upnp? ( net-libs/gssdp:= )
+ websocket? ( >=net-libs/libsoup-2.50:2.4 )
+ zeroconf? ( net-dns/avahi[dbus] )
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.5
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ virtual/pkgconfig
+ fbcon? ( virtual/os-headers )
+"
+RDEPEND="${COMMON_DEPEND}
+ net-libs/glib-networking[ssl]
+"
+
+eventd_check_compiler() {
+ if [[ ${MERGE_TYPE} != "binary" ]] && ! test-flag-CXX -std=c++11; then
+ die "Your compiler lacks C++11 support. Use GCC>=4.7.0 or Clang>=3.3."
+ fi
+}
+
+pkg_pretend() {
+ eventd_check_compiler
+}
+
+pkg_setup() {
+ if use ipv6; then
+ CONFIG_CHECK=$(usex test 'IPV6' '~IPV6')
+ linux-info_pkg_setup
+ fi
+ eventd_check_compiler
+}
+
+src_prepare() {
+ default_src_prepare
+
+ # Workaround Gentoo bug 604398.
+ sed -i \
+ -e 's|libspeechd|speech-dispatcher/libspeechd|g' \
+ plugins/tts/src/tts.c || die
+
+ # Prevent access violations from introspection metadata generation.
+ xdg_environment_reset
+}
+
+eventd_use_enable() {
+ echo "-Denable-${2:-${1}}=$(usex ${1} 'true' 'false')" || die
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dsystemduserunitdir="$(systemd_get_userunitdir)"
+ -Dsystemdsystemunitdir="$(systemd_get_systemunitdir)"
+ -Ddbussessionservicedir="${EPREFIX}/usr/share/dbus-1/services"
+ $(eventd_use_enable websocket)
+ $(eventd_use_enable zeroconf dns-sd)
+ $(eventd_use_enable upnp ssdp)
+ $(eventd_use_enable ipv6)
+ $(eventd_use_enable systemd)
+ $(eventd_use_enable notification notification-daemon)
+ # Wayland plugin requires wayland-wall, which is currently WIP.
+ # See https://github.com/wayland-wall/wayland-wall/issues/1
+ -Denable-nd-wayland="false"
+ $(eventd_use_enable X nd-xcb)
+ $(eventd_use_enable fbcon nd-fbdev)
+ $(eventd_use_enable purple im)
+ $(eventd_use_enable pulseaudio sound)
+ $(eventd_use_enable speech tts)
+ $(eventd_use_enable libnotify)
+ $(eventd_use_enable libcanberra)
+ $(eventd_use_enable introspection gobject-introspection)
+ $(eventd_use_enable debug)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ EVENTD_TESTS_TMP_DIR="${T}" meson_src_test
+}
+
+pkg_postinst() {
+ if { use notification || use libnotify; } && ! has_version 'gnome-base/librsvg'; then
+ elog
+ elog "For SVG icons in notifications, please install 'gnome-base/librsvg'."
+ elog
+ fi
+}
diff --git a/net-misc/eventd/metadata.xml b/net-misc/eventd/metadata.xml
new file mode 100644
index 000000000000..921e71edf64f
--- /dev/null
+++ b/net-misc/eventd/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>itumaykin+gentoo@gmail.com</email>
+ <name>Coacher</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="libcanberra">Enable plugin for sounds via <pkg>media-libs/libcanberra</pkg></flag>
+ <flag name="libnotify">Enable plugin to relay events to notification daemon
+ (Note: not required for local notifications via <pkg>net-misc/eventd</pkg>)</flag>
+ <flag name="notification">Enable plugin to display on-screen notifications</flag>
+ <flag name="purple">Enable plugin for IM notifications via libpurple</flag>
+ <flag name="speech">Enable plugin for Text-To-Speech support</flag>
+ <flag name="websocket">Enable support for WebSocket protocol</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">sardemff7/eventd</remote-id>
+ </upstream>
+</pkgmetadata>