summaryrefslogtreecommitdiff
path: root/net-misc/endlessh/endlessh-1.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-25 20:34:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-25 20:34:27 +0000
commit0f15659d48c193027158492acb726297501202c5 (patch)
tree5502ba879a78b759da28441d418dbbfe08bd8f03 /net-misc/endlessh/endlessh-1.1-r2.ebuild
parent93a93e9a3b53c1a73142a305ea1f8136846942ee (diff)
gentoo xmass resync : 25.12.2021
Diffstat (limited to 'net-misc/endlessh/endlessh-1.1-r2.ebuild')
-rw-r--r--net-misc/endlessh/endlessh-1.1-r2.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/net-misc/endlessh/endlessh-1.1-r2.ebuild b/net-misc/endlessh/endlessh-1.1-r2.ebuild
new file mode 100644
index 000000000000..5112f7ee494f
--- /dev/null
+++ b/net-misc/endlessh/endlessh-1.1-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd toolchain-funcs
+
+DESCRIPTION="SSH tarpit that slowly sends and endless banner"
+HOMEPAGE="https://github.com/skeeto/endlessh"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/skeeto/${PN}.git"
+else
+ SRC_URI="https://github.com/skeeto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 ~arm ~arm64 ppc64 x86"
+fi
+
+LICENSE="Unlicense"
+SLOT="0"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1-syslog-help.patch
+)
+
+src_prepare() {
+ default
+
+ tc-export CC
+
+ sed -i \
+ -e 's/^CC/CC?/' \
+ -e 's/^CFLAGS =/CFLAGS +=/' \
+ -e 's/ -Os//' \
+ -e 's/^LDFLAGS/LDFLAGS?/' \
+ -e 's/^PREFIX/PREFIX?/' \
+ Makefile || die
+
+ sed -i -e "/^ExecStart=/ s:=/usr/local:=${EPREFIX}/usr:" \
+ -e /InaccessiblePaths/d util/endlessh.service || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+
+ einstalldocs
+
+ newinitd "${FILESDIR}"/endlessh.initd endlessh
+ newconfd "${FILESDIR}"/endlessh.confd endlessh
+
+ systemd_dounit util/endlessh.service
+
+ insinto /usr/share/${PN}
+ doins util/{pivot.py,schema.sql}
+}
+
+pkg_postinst() {
+ elog "Log parsing script installed to ${EPREFIX}/usr/share/${PN}"
+ elog "Install dev-python/pyrfc3339 if you are going to use it"
+}