summaryrefslogtreecommitdiff
path: root/net-misc/endlessh/endlessh-1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
commiteab5731cdf11d4ae8cdf111461d46fd96c5bdd37 (patch)
treece35c6d01b5ff5de95c3a20fef853b9a6518ad2e /net-misc/endlessh/endlessh-1.0.ebuild
parentb7ebc951da8800f711142f69d9d958bde67a112d (diff)
gentoo resync : 04.05.2019
Diffstat (limited to 'net-misc/endlessh/endlessh-1.0.ebuild')
-rw-r--r--net-misc/endlessh/endlessh-1.0.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/net-misc/endlessh/endlessh-1.0.ebuild b/net-misc/endlessh/endlessh-1.0.ebuild
new file mode 100644
index 000000000000..e0a840877f36
--- /dev/null
+++ b/net-misc/endlessh/endlessh-1.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd toolchain-funcs
+
+DESCRIPTION="SSH tarpit that slowly sends and endless banner"
+HOMEPAGE="https://github.com/skeeto/endlessh"
+
+if [ ${PV} == "9999" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/skeeto/${PN}.git"
+else
+ SRC_URI="https://github.com/skeeto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Unlicense"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+BDEPEND=""
+
+src_prepare() {
+ default
+
+ tc-export CC
+
+ sed -i \
+ -e 's/^CC/CC?/' \
+ -e 's/^CFLAGS =/CFLAGS +=/' \
+ -e 's/ -Os//' \
+ -e 's/^LDFLAGS/LDFLAGS?/' \
+ -e 's/^PREFIX/PREFIX?/' \
+ Makefile || die
+
+ sed -i -e "/^ExecStart=/ s:=/opt/endlessh:=${EPREFIX}/usr/bin:" \
+ util/endlessh.service || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+
+ einstalldocs
+
+ newinitd "${FILESDIR}"/endlessh.initd-r1 endlessh
+ newconfd "${FILESDIR}"/endlessh.confd-r1 endlessh
+
+ systemd_dounit util/endlessh.service
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/logrotated-r1" endlessh
+
+ insinto /usr/share/"${PN}"
+ doins util/{pivot.py,schema.sql}
+}
+
+pkg_postinst() {
+ elog "Log parsing script installed to ${EPREFIX}/usr/share/${PN}"
+ elog "Install dev-python/pyrfc3339 if you are going to use it"
+}