summaryrefslogtreecommitdiff
path: root/net-misc/ena-driver/ena-driver-2.9.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-05 16:23:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-05 16:23:54 +0100
commit44a22ab89258383202cae3037c3a5685aa903251 (patch)
tree76789a8fb67642ae7635df789a9bb83125ec127d /net-misc/ena-driver/ena-driver-2.9.1.ebuild
parent9aa62a2a35904a08cbf2e884d3abd89d893daf91 (diff)
gentoo auto-resync : 05:09:2023 - 16:23:54
Diffstat (limited to 'net-misc/ena-driver/ena-driver-2.9.1.ebuild')
-rw-r--r--net-misc/ena-driver/ena-driver-2.9.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-misc/ena-driver/ena-driver-2.9.1.ebuild b/net-misc/ena-driver/ena-driver-2.9.1.ebuild
new file mode 100644
index 000000000000..eb8ed9525827
--- /dev/null
+++ b/net-misc/ena-driver/ena-driver-2.9.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-mod-r1
+
+DESCRIPTION="Amazon EC2 Elastic Network Adapter (ENA) kernel driver"
+HOMEPAGE="https://docs.aws.amazon.com/AWSEC2/latest/UserGuide/enhanced-networking-ena.html"
+SRC_URI="https://github.com/amzn/amzn-drivers/archive/ena_linux_${PV}.tar.gz -> ${P}-linux.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}/amzn-drivers-ena_linux_${PV}/kernel/linux/ena"
+
+CONFIG_CHECK="PCI_MSI !CPU_BIG_ENDIAN DIMLIB"
+DOCS=(
+ README.rst
+ RELEASENOTES.md
+ ENA_Linux_Best_Practices.rst
+)
+
+src_compile() {
+ local modlist=( ena=net )
+ local modargs=( CONFIG_MODULE_SIG=n BUILD_KERNEL="${KV_FULL}" )
+ linux-mod-r1_src_compile
+}