summaryrefslogtreecommitdiff
path: root/net-misc/ena-driver/ena-driver-2.8.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-05 16:23:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-05 16:23:54 +0100
commit44a22ab89258383202cae3037c3a5685aa903251 (patch)
tree76789a8fb67642ae7635df789a9bb83125ec127d /net-misc/ena-driver/ena-driver-2.8.7.ebuild
parent9aa62a2a35904a08cbf2e884d3abd89d893daf91 (diff)
gentoo auto-resync : 05:09:2023 - 16:23:54
Diffstat (limited to 'net-misc/ena-driver/ena-driver-2.8.7.ebuild')
-rw-r--r--net-misc/ena-driver/ena-driver-2.8.7.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/net-misc/ena-driver/ena-driver-2.8.7.ebuild b/net-misc/ena-driver/ena-driver-2.8.7.ebuild
deleted file mode 100644
index 7c93be223a28..000000000000
--- a/net-misc/ena-driver/ena-driver-2.8.7.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit linux-mod
-
-DESCRIPTION="Amazon EC2 Elastic Network Adapter (ENA) kernel driver"
-HOMEPAGE="https://docs.aws.amazon.com/AWSEC2/latest/UserGuide/enhanced-networking-ena.html"
-SRC_URI="https://github.com/amzn/amzn-drivers/archive/ena_linux_${PV}.tar.gz -> ${P}-linux.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-
-BDEPEND="app-arch/unzip"
-
-S="${WORKDIR}/amzn-drivers-ena_linux_${PV}/kernel/linux/ena"
-
-MODULE_NAMES="ena(net:${S}:${S})"
-BUILD_TARGETS="all"
-
-CONFIG_CHECK="PCI_MSI !CPU_BIG_ENDIAN DIMLIB"
-
-pkg_setup() {
- linux-mod_pkg_setup
- BUILD_PARAMS="CONFIG_MODULE_SIG=n KERNEL_DIR=${KV_DIR}"
-}
-
-src_prepare() {
- default
-
- sed -i -e 's!/lib/modules/\$(BUILD_KERNEL)/build!$(KERNEL_DIR)!g' \
- "Makefile" || die "Unable to fix Makefile"
-}
-
-src_install() {
- linux-mod_src_install
- dodoc README.rst RELEASENOTES.md
-}