summaryrefslogtreecommitdiff
path: root/net-misc/electron-cash/files/3.3.6-no-user-root.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /net-misc/electron-cash/files/3.3.6-no-user-root.patch
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'net-misc/electron-cash/files/3.3.6-no-user-root.patch')
-rw-r--r--net-misc/electron-cash/files/3.3.6-no-user-root.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-misc/electron-cash/files/3.3.6-no-user-root.patch b/net-misc/electron-cash/files/3.3.6-no-user-root.patch
new file mode 100644
index 000000000000..f5f0aecf382f
--- /dev/null
+++ b/net-misc/electron-cash/files/3.3.6-no-user-root.patch
@@ -0,0 +1,27 @@
+--- a/setup.py
++++ b/setup.py
+@@ -33,23 +33,7 @@
+ # Use per-user */share directory if the global one is not writable or if a per-user installation
+ # is attempted
+ user_share = os.environ.get('XDG_DATA_HOME', os.path.expanduser('~/.local/share'))
+- system_share = os.path.join(opts.prefix_path, "share")
+- if not opts.is_user:
+- # Not neccarily a per-user installation try system directories
+- if os.access(opts.root_path + system_share, os.W_OK):
+- # Global /usr/share is writable for us – so just use that
+- share_dir = system_share
+- elif not os.path.exists(opts.root_path + system_share) and os.access(opts.root_path, os.W_OK):
+- # Global /usr/share does not exist, but / is writable – keep using the global directory
+- # (happens during packaging)
+- share_dir = system_share
+- else:
+- # Neither /usr/share (nor / if /usr/share doesn't exist) is writable, use the
+- # per-user */share directory
+- share_dir = user_share
+- else:
+- # Per-user installation
+- share_dir = user_share
++ share_dir = os.path.join(opts.prefix_path, "share")
+ data_files += [
+ # Menu icon
+ # Menu entry