summaryrefslogtreecommitdiff
path: root/net-misc/electron-cash/electron-cash-4.2.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-07 07:06:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-07 07:06:38 +0000
commita03bc69159ecc073f051ca2079848553a8e34664 (patch)
treeee5424e043dfb1fe51f12594640edff5846b796e /net-misc/electron-cash/electron-cash-4.2.11.ebuild
parent905e7d07da40378586e71ece65bd962b0b00c578 (diff)
gentoo auto-resync : 07:03:2024 - 07:06:38
Diffstat (limited to 'net-misc/electron-cash/electron-cash-4.2.11.ebuild')
-rw-r--r--net-misc/electron-cash/electron-cash-4.2.11.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/net-misc/electron-cash/electron-cash-4.2.11.ebuild b/net-misc/electron-cash/electron-cash-4.2.11.ebuild
index 8028eb404b26..993cd0db3cc4 100644
--- a/net-misc/electron-cash/electron-cash-4.2.11.ebuild
+++ b/net-misc/electron-cash/electron-cash-4.2.11.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI="8"
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
PYTHON_REQ_USE="ncurses?"
@@ -32,6 +33,8 @@ REQUIRED_USE="
vkb? ( qt5 )
"
+BDEPEND="${DISTUTILS_DEPS}"
+
RDEPEND="
dev-python/dnspython[${PYTHON_USEDEP}]
dev-python/ecdsa[${PYTHON_USEDEP}]
@@ -65,7 +68,9 @@ src_prepare() {
eapply "${FILESDIR}/3.3.6-no-user-root.patch"
# Prevent icon from being installed in the wrong location
- sed -i '/icons/d' setup.py || die
+ sed -e '/icons/d' \
+ -e "s:\\(os.path.join(\\)share_dir:\\1'share':" \
+ -i setup.py || die
if use qt5; then
pyrcc5 icons.qrc -o electroncash_gui/qt/icons_rc.py || die