summaryrefslogtreecommitdiff
path: root/net-misc/efax/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /net-misc/efax/files
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'net-misc/efax/files')
-rw-r--r--net-misc/efax/files/efax-0.9a-fax-command.patch4
-rw-r--r--net-misc/efax/files/efax-0.9a-fno-common.patch32
-rw-r--r--net-misc/efax/files/efax-0.9a-strip.patch14
3 files changed, 48 insertions, 2 deletions
diff --git a/net-misc/efax/files/efax-0.9a-fax-command.patch b/net-misc/efax/files/efax-0.9a-fax-command.patch
index 92bec22aa879..b6543432d2e2 100644
--- a/net-misc/efax/files/efax-0.9a-fax-command.patch
+++ b/net-misc/efax/files/efax-0.9a-fax-command.patch
@@ -1,5 +1,5 @@
---- fax 2010/07/11 02:05:19 1.1
-+++ fax 2010/07/11 02:05:37
+--- a/fax
++++ b/fax
@@ -773,6 +773,7 @@
$GS -q -sDEVICE=tiffg3 -r$RES -dNOPAUSE -dSAFER \
-sOutputFile=$BASENAME.%03d \
diff --git a/net-misc/efax/files/efax-0.9a-fno-common.patch b/net-misc/efax/files/efax-0.9a-fno-common.patch
new file mode 100644
index 000000000000..e27fa082e4b8
--- /dev/null
+++ b/net-misc/efax/files/efax-0.9a-fno-common.patch
@@ -0,0 +1,32 @@
+--- a/efaxos.h
++++ b/efaxos.h
+@@ -13,7 +13,6 @@
+
+ /* Bit order reversal table. */
+
+-extern unsigned char normalbits [ ] ;
+
+ typedef enum ttymodes /* serial port modes: */
+ {
+--- a/efaxlib.h
++++ b/efaxlib.h
+@@ -208,7 +208,7 @@
+ /* Bit reversal lookup tables (note that the `normalbits' array
+ is the one actually used for the bit reversal. */
+
+-uchar reversebits [ 256 ], normalbits [ 256 ] ;
++extern uchar reversebits [ 256 ], normalbits [ 256 ] ;
+
+ void initbittab(void) ;
+
+--- a/efaxlib.c
++++ b/efaxlib.c
+@@ -25,6 +25,8 @@
+
+ short short256 = 256 ; /* for endian-ness detection */
+
++uchar reversebits [ 256 ], normalbits [ 256 ] ;
++
+ /* Make sure printf strings have only %d escapes and n or fewer
+ of them. Returns 0 if OK, 1 on error. */
+
diff --git a/net-misc/efax/files/efax-0.9a-strip.patch b/net-misc/efax/files/efax-0.9a-strip.patch
new file mode 100644
index 000000000000..a707b7e85aef
--- /dev/null
+++ b/net-misc/efax/files/efax-0.9a-strip.patch
@@ -0,0 +1,14 @@
+--- a/Makefile
++++ b/Makefile
+@@ -25,11 +25,9 @@
+
+ efax: efax.o efaxlib.o efaxio.o efaxos.o efaxmsg.o
+ $(CC) -o efax $(LDFLAGS) efax.o efaxlib.o efaxio.o efaxos.o efaxmsg.o
+- strip efax
+
+ efix: efix.o efaxlib.o efaxmsg.o
+ $(CC) -o efix $(LDFLAGS) efix.o efaxlib.o efaxmsg.o
+- strip efix
+
+ install:
+ cp fax efax efix $(BINDIR)