summaryrefslogtreecommitdiff
path: root/net-misc/econnman/econnman-1.1_p20160305-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-08 12:03:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-08 12:03:01 +0100
commit522fa4e6f267ba688a264ceec8d6c79663b61219 (patch)
tree67895f3a8243148309fbd841dabba28c37f4ed4a /net-misc/econnman/econnman-1.1_p20160305-r1.ebuild
parent32c16465e56b0122cf6e5a4625e9c7b56b107b07 (diff)
gentoo auto-resync : 08:10:2023 - 12:03:01
Diffstat (limited to 'net-misc/econnman/econnman-1.1_p20160305-r1.ebuild')
-rw-r--r--net-misc/econnman/econnman-1.1_p20160305-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/econnman/econnman-1.1_p20160305-r1.ebuild b/net-misc/econnman/econnman-1.1_p20160305-r1.ebuild
new file mode 100644
index 000000000000..699902201f36
--- /dev/null
+++ b/net-misc/econnman/econnman-1.1_p20160305-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit autotools python-single-r1
+
+DESCRIPTION="ConnMan User Interface written with EFL & python"
+HOMEPAGE="https://phab.enlightenment.org/w/projects/econnman/ https://www.enlightenment.org/"
+SRC_URI="https://dev.gentoo.org/~juippis/distfiles/${P}.tar.xz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ dev-libs/efl[X,connman]
+ $(python_gen_cond_dep '
+ dev-python/python-efl[${PYTHON_USEDEP}]
+ ')"
+
+src_prepare() {
+ default
+ python_fix_shebang econnman-bin.in
+ eautoreconf
+}
+
+src_install() {
+ default
+ rm -r "${ED}"/var/ || die
+}