summaryrefslogtreecommitdiff
path: root/net-misc/dropbox-cli/dropbox-cli-2020.03.04.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /net-misc/dropbox-cli/dropbox-cli-2020.03.04.ebuild
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'net-misc/dropbox-cli/dropbox-cli-2020.03.04.ebuild')
-rw-r--r--net-misc/dropbox-cli/dropbox-cli-2020.03.04.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-misc/dropbox-cli/dropbox-cli-2020.03.04.ebuild b/net-misc/dropbox-cli/dropbox-cli-2020.03.04.ebuild
new file mode 100644
index 000000000000..6980da3d4fb6
--- /dev/null
+++ b/net-misc/dropbox-cli/dropbox-cli-2020.03.04.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-r1 bash-completion-r1
+
+DESCRIPTION="Cli interface for dropbox (python), part of nautilus-dropbox"
+HOMEPAGE="https://www.dropbox.com/"
+SRC_URI="https://dev.gentoo.org/~grozin/${P}.py.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="net-misc/dropbox
+ ${PYTHON_DEPS}
+ dev-python/pygpgme[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}
+
+src_install() {
+ newbin ${P}.py ${PN}
+ python_replicate_script "${D}"/usr/bin/${PN}
+ newbashcomp "${FILESDIR}"/${PN}-19-completion ${PN}
+}