summaryrefslogtreecommitdiff
path: root/net-misc/datapipe/datapipe-1.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
commitb2be182d49eea46686b5cf2680d457df61e89dc4 (patch)
treec66442ced2011c5ca81c3114cc51041e314c6d33 /net-misc/datapipe/datapipe-1.0-r2.ebuild
parente23cdda4dbb0c83b9e682ab5e916085a35203da5 (diff)
gentoo resync : 30.06.2018
Diffstat (limited to 'net-misc/datapipe/datapipe-1.0-r2.ebuild')
-rw-r--r--net-misc/datapipe/datapipe-1.0-r2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-misc/datapipe/datapipe-1.0-r2.ebuild b/net-misc/datapipe/datapipe-1.0-r2.ebuild
new file mode 100644
index 000000000000..503b4e448264
--- /dev/null
+++ b/net-misc/datapipe/datapipe-1.0-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="bind a local port and connect it to a remote socket"
+HOMEPAGE="http://http.distributed.net/pub/dcti/unsupported/"
+SRC_URI="ftp://ftp.distributed.net/pub/dcti/unsupported/${P}.tar.gz http://http.distributed.net/pub/dcti/unsupported/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~arm ~amd64"
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o datapipe datapipe.c
+}
+
+src_install() {
+ einstalldocs
+ dobin datapipe
+ dodoc datapipe.txt
+}