summaryrefslogtreecommitdiff
path: root/net-misc/dahdi-tools/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /net-misc/dahdi-tools/files
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'net-misc/dahdi-tools/files')
-rw-r--r--net-misc/dahdi-tools/files/dahdi-tools-3.1.0-cplusplusexternc.patch26
-rw-r--r--net-misc/dahdi-tools/files/dahdi-tools-3.1.0-execinfo.patch40
-rw-r--r--net-misc/dahdi-tools/files/dahdi-tools-3.1.0-fno-common.patch39
3 files changed, 105 insertions, 0 deletions
diff --git a/net-misc/dahdi-tools/files/dahdi-tools-3.1.0-cplusplusexternc.patch b/net-misc/dahdi-tools/files/dahdi-tools-3.1.0-cplusplusexternc.patch
new file mode 100644
index 000000000000..37d1402c404f
--- /dev/null
+++ b/net-misc/dahdi-tools/files/dahdi-tools-3.1.0-cplusplusexternc.patch
@@ -0,0 +1,26 @@
+diff --git a/./dahdi-tools-3.1.0/xpp/hexfile.h.o b/./dahdi-tools-3.1.0/xpp/hexfile.h
+index 33ff50d..3d03f98 100644
+--- a/xpp/hexfile.h
++++ b/xpp/hexfile.h
+@@ -70,7 +70,9 @@ struct hexdata {
+ };
+
+
+-__BEGIN_DECLS
++#ifdef __cpluplus
++extern "C" {
++#endif
+
+ typedef void (*parse_hexfile_report_func_t)(int level, const char *msg, ...)
+ #ifdef __GNUC__
+@@ -86,6 +88,9 @@ int dump_hexfile2(struct hexdata *hexdata, const char *outfile, uint8_t maxwidth
+ void dump_binary(struct hexdata *hexdata, const char *outfile);
+ void gen_hexline(const uint8_t *data, uint16_t addr, size_t len, FILE *output);
+ int bsd_checksum(struct hexdata *hexdata);
+-__END_DECLS
++
++#ifdef __cpluplus
++}
++#endif
+
+ #endif
diff --git a/net-misc/dahdi-tools/files/dahdi-tools-3.1.0-execinfo.patch b/net-misc/dahdi-tools/files/dahdi-tools-3.1.0-execinfo.patch
new file mode 100644
index 000000000000..b222a85d8cb9
--- /dev/null
+++ b/net-misc/dahdi-tools/files/dahdi-tools-3.1.0-execinfo.patch
@@ -0,0 +1,40 @@
+--- a/configure.ac 2020-03-28 22:28:35.614340050 +0200
++++ b/configure.ac 2020-03-28 22:28:55.084181570 +0200
+@@ -161,6 +161,7 @@
+ # Checks for header files.
+ AC_CHECK_HEADERS([sys/soundcard.h linux/soundcard.h])
+ AC_CHECK_HEADERS([arpa/inet.h fcntl.h limits.h netinet/in.h stdint.h stdlib.h string.h sys/ioctl.h sys/param.h sys/socket.h sys/time.h syslog.h unistd.h])
++AC_CHECK_HEADERS([execinfo.h])
+
+ # Checks for typedefs, structures, and compiler characteristics.
+ AC_C_INLINE
+--- a/xpp/xtalk/debug.c 2020-03-28 22:41:43.507810560 +0200
++++ b/xpp/xtalk/debug.c 2020-03-28 22:41:10.538087608 +0200
+@@ -27,8 +27,10 @@
+ #include <stdarg.h>
+ #include <syslog.h>
+-#include <execinfo.h>
+ #include <xtalk/debug.h>
+ #include <autoconfig.h>
++#ifdef HAVE_EXECINFO_H
++#include <execinfo.h>
++#endif
+
+ int verbose = LOG_INFO;
+ int debug_mask;
+@@ -61,6 +63,7 @@
+ /* from glibc info(1) */
+ void print_backtrace(FILE *fp)
+ {
++#ifdef HAVE_EXECINFO_H
+ void *array[10];
+ size_t size;
+ char **strings;
+@@ -71,4 +74,7 @@
+ for (i = 0; i < size; i++)
+ fprintf(fp, "%s\n", strings[i]);
+ free(strings);
++#else
++ fprintf(fp, "backtrace information only available if execinfo.h is available.\n");
++#endif
+ }
diff --git a/net-misc/dahdi-tools/files/dahdi-tools-3.1.0-fno-common.patch b/net-misc/dahdi-tools/files/dahdi-tools-3.1.0-fno-common.patch
new file mode 100644
index 000000000000..3ca5bd2aa09b
--- /dev/null
+++ b/net-misc/dahdi-tools/files/dahdi-tools-3.1.0-fno-common.patch
@@ -0,0 +1,39 @@
+diff --git a/xpp/mpptalk.c b/xpp/mpptalk.c
+index fdb34f1..8fb3687 100644
+--- a/xpp/mpptalk.c
++++ b/xpp/mpptalk.c
+@@ -237,7 +237,7 @@ union XTALK_PDATA(MPP) {
+ MEMBER(MPP, TWS_PORT_GET_REPLY);
+ MEMBER(MPP, TWS_PWR_GET);
+ MEMBER(MPP, TWS_PWR_GET_REPLY);
+-} PACKED members;
++} PACKED;
+
+ /*
+ * Statuses
+diff --git a/xpp/xtalk/xtalk_raw.c b/xpp/xtalk/xtalk_raw.c
+index 49e47d5..251a502 100644
+--- a/xpp/xtalk/xtalk_raw.c
++++ b/xpp/xtalk/xtalk_raw.c
+@@ -48,7 +48,7 @@ CMD_DEF(XTALK, ACK,
+
+ union XTALK_PDATA(XTALK) {
+ MEMBER(XTALK, ACK);
+-} PACKED members;
++} PACKED;
+
+ const struct xtalk_protocol xtalk_raw_proto = {
+ .name = "XTALK-RAW",
+diff --git a/xpp/xtalk/xtalk_sync.c b/xpp/xtalk/xtalk_sync.c
+index 18a5cad..ffa79d2 100644
+--- a/xpp/xtalk/xtalk_sync.c
++++ b/xpp/xtalk/xtalk_sync.c
+@@ -60,7 +60,7 @@ union XTALK_PDATA(XTALK) {
+ MEMBER(XTALK, ACK);
+ MEMBER(XTALK, PROTO_GET);
+ MEMBER(XTALK, PROTO_GET_REPLY);
+-} PACKED members;
++} PACKED;
+
+ const struct xtalk_protocol xtalk_sync_proto = {
+ .name = "XTALK-SYNC",